3 Replies Latest reply on Apr 3, 2018 4:41 AM by Madhu Lakshmipathy

    BulkLoop

    burakakde_3248161

      Dear all;

       

      I am using CY8CKIT-050 Psoc 5LP dev kit and I am trying to run "AN70983\Bulkloop_Solution". I have modified the VID and PID accordingly.

      const int VID = 0x04B4;

      const int PID = 0x8051;

       

      I have also followed the USBFS Bulk Wraparound Example Project 3.0.

       

      When I run the code I get the following:

       

      Capture.PNG

       

      Capture.PNG

       

      In short; the driver is OK and the device is visible at the left panel. I can also send and read data by using "CyPress USB Console". However I cannot do it with the mentioned program. So how can I send and receive data by using the mentioned program? I am using that because it is open source. Sadly the source code for "CyPress USB Console" is confidential. So what should I do or what should I modify to make the program work? (especially in c++)

       

      Looking forward for your reply.

      Yours Sincerely...

        • 1. Re: BulkLoop
          anks

          Can you attach the Bulkloop VCS program project with us.

          • 2. Re: BulkLoop
            burakakde_3248161

            Thanks for the swift reply.

             

            Here is the code we are dealing with.

            tul - Google Drive

             

            The project that I used in the post below is in the following library:

            AN70983\Bulkloop_Solution

             

            I have also tried to compile the C++ version (I need to make the C++ version work) which is in the following directory:

            AN70983\Bulkloop_Solution\Bulkloop_Solution\VC++ Application\Source\Bulkloop_VCPP\Bulkloop_VCPP

            but this time I get the following error:

            Capture.PNG

             

            I have also tried to run the "Bulkloop_VCPP.exe" which is in the following directory:

            C:\Users\burak\Desktop\AN70983\Bulkloop_Solution\Bulkloop_Solution\VC++ Application\Source\Bulkloop_VCPP\Bulkloop_VCPP\Debug

             

            But I get the same error once more.

             

            So how can I solve the problems I mentioned?

            I need to send/receive data using C++ in bulkloop to CY8CKIT-050 PSoC 5LP Dev Kit.

            As you can see I am using the codes provided by CyPress but as far as I understand C++ is not a popular solution.

             

            Thanks for your time and effort.

            Looking forward for your reply.

             

            Yours Sincerely...

            • 3. Re: BulkLoop
              Madhu Lakshmipathy

              Hi,

               

              It seems that the bulkloop application needs the OUT endpoint to be 0x02 and IN endpoint to be 0x86. Can you please modify accordingly the endpoint numbers in your device and try?

               

              I tried with Cypress FX3 USB controller and configured the device to have 0x02 and 0x86 endpoints and I was able to get success.

               

              cpp.PNG

               

              Regards,

              -Madhu