6 Replies Latest reply on Mar 23, 2018 5:13 PM by gelber.mahecha_3173111

    UART port can't be accessed

    gelber.mahecha_3173111

      This is probably a very simple/dumb question, but I'm new with Cypress technology, and after trying in different ways, I can't make any of my projects to use a UART module to report the status of the execution.

       

      The project is compiled and transferred without any problem to my PSoC 6 BLE Pioneer kit, but for some reason, I can't open the serial port with the terminal app (I'm using putty). I even tried with one of the samples (UART_Low_Level_DMA) without any luck. When opening in putty, it reports this error:

      puttyerrror.jpg

       

       

      I've confirmed with the device manager, the port (in my case COM12) and tried with other different ports and configurations with a similar result.   This is how I'm doing my test:

      1. With PSoC Creator 4.2 compile and upload the program to my pioneer kit
      2. After closing Creator, I open putty and select the port and the parameters (115200, 8,N,1,N)

       

      I'm using W10 64 bits and confirmed that putty can open other serial ports (i.e., a simple Arduino board connected). Thanks for your feedback.