3 Replies Latest reply on Mar 26, 2018 5:22 AM by chaplin.u_1533771

    Indication is not work ?

    chaplin.u_1533771

      I made some example for check "SendIndication". I used thermometer profile.

      Connected with CySmart application and try to check value of pressed button but it not send any data ( or data not changed).

      attached project. please help !

        • 1. Re: Indication is not work ?
          e.pratt_1639216

          You need to have the Notifications/Indications Enabled for the service from the CySmart window.

          See this thread: http://origin-www.cypress.com/forum/psoc-4-ble/enable-notifications-client

          • 2. Re: Indication is not work ?
            chaplin.u_1533771

            If I use CySmart  application and after connect I click on "thermometer " application send Indications Enable to device. It`s fact.

            • 3. Re: Indication is not work ?
              e.pratt_1639216

              You are saying that it still does the same thing when you check for send indication data after enabling the indications to be enabled on the cysmart application and under the client characteristic descriptor?

               

              Some things I would recommend looking at your code: Move the indication function call outside of the interrupt. Generally you should do as little as possible within the interrupt handler, and should call the cyble functions from main loop (or the callback event handler, but try to avoid that if you can as well)

               

              Secondly, you can check if the indication is successful on the PSoC device by checking for the event:

              CYBLE_EVT_HTSS_INDICATION_CONFIRMED or CYBLE_EVT_GATTS_HANDLE_VALUE_CNF depending on successful delivery.

              Also, you can check the return value of the function call of type/values:

              *  Return value is of type CYBLE_API_RESULT_T.

              *   * CYBLE_ERROR_OK - The request handled successfully.

              *   * CYBLE_ERROR_INVALID_PARAMETER - Validation of the input parameter failed.

              *   * CYBLE_ERROR_INVALID_OPERATION - This operation is not permitted.

              *   * CYBLE_ERROR_INVALID_STATE - Connection with the client is not established.

              *   * CYBLE_ERROR_MEMORY_ALLOCATION_FAILED - Memory allocation failed.

              *   * CYBLE_ERROR_IND_DISABLED - Indication is not enabled by the client.

              If it does not return CYBLE_ERROR_OK when you call it, then it didn't work.