3 Replies Latest reply on Mar 29, 2018 6:42 PM by wahy

    Dump the firmware written into MB90F867AS mcu

    AlessandroOfficial

      How I dump a firmware that is written into a MB90F867AS mcu?

      I have read the datasheet and the fujitsu guide, but after I make all the connections through rs232 cable it still doesn't work. My pc don't recognise the mcu. I probably miss something in the links, but I do not know what.

      I have shorted-circuit GND pins (pin 16, 77 and 78) and connected to pin 5 in rs232 cable; the SOT0 pin is connected to 3rd pin and SIN0 to 2nd; MD1 and MD2 are shorted-circuit with VCC (that is the pin 15, but is not connected to rs232 cable) and MD0 to GND (I have soldered carefully the wires directly to MCU pins); at this point i set RSTX pin to low by connect it to GND and then I turn on the circuit on which the MB90F867AS mcu is settled; when Flash MCU programmer (the software that I use for read/write) ask me, I set it to high by connect it to VCC but it doesn't recognise nothing! I don't understand where I'm wrong, if someone could please give me explanations, I would be grateful.

      Thank you

        • 1. Re: Dump the firmware written into MB90F867AS mcu
          yliu

          This is pretty old product, no much experience in this community, but are you using the "pcw16lx-v01l27.zip" available from FLASH MCU Programmer ? what message do you see when you conclude it recognized nothing?

          • 2. Re: Dump the firmware written into MB90F867AS mcu
            AlessandroOfficial

            Yes, I am using this software. The first message I see on screen is something like "please reset microcontroller before continuing", and after I sent the reset signal, it comes out "ERROR!! No. 003 timeout error". It recognise nothing because the download phase does not happen, and the exactly same error comes out when there's only the RS232 cable connected into PC, even without the microcontroller. A very few times, apparently without precise reason, it came out this: "ERROR!! MCU: 98H No. 001 Download error". For the errors I have checked the various documentations: the error 003 case it's probably due to a bad hardware configuration (but it's the same all the times...), while sometimes that the PC seems to recognise the microcontroller for a while, but after a short time it fails the download phase and give me the 001 error. Anyhow, the 001 error it comes out a very few times, and I don't know how to replicate this particular case.

            • 3. Re: Dump the firmware written into MB90F867AS mcu
              wahy

              Hello Alessandro,

               

              1. What's the purpose to read out the firmware in MCU? Please kindly note it's impossible to readout any data from MCU if it's secured.

               

              2. As you are using MB90F867, please kindly download the Flash MCU programmer for 16LX ((FLASH MCU Programmer for F2MC-16LX) ) and select the right MCU in the Flash MCU Programmer.

               

              3. Please kindly refer to the section 3/4 of PCW16LXe.pdf for on board programming connection based on your part number.

               

              4. Please check if the right COM port was configured in Flash MCU Programmer>>Set Environment.

               

              Best regards,

              Amy Wang