1 Reply Latest reply on Mar 14, 2018 2:20 PM by Madhu Lakshmipathy

    GPIF-II Master Interface Master and Slave FIFO device not recognized [re-posted]


      Hi, I am re-posting the same post (GPIF-II Master Interface Master and Slave FIFO device not recognized ). Kindly reply ASAP.


      I have two CYUSB3KIT-003 explore kits. Here, I am following "AN87216 - Designing a GPIF II Master Interface" guide to make exchange of data between two hosts as Master and Slave FIFO.


      I downloaded and uploaded pre-built firmware images for both the slave device and master device (Autoslave.img and Automaster.img). After uploading, Cypress USB Control Center software shows nothing (before uploading Cypress USB Control Center lists both devices as Cypress FX3 USB Bootloader device). Then, I cross-checked in the device manager, both the device drivers not installed (both are shown as FX3 in other devices). I have tried all the samples from the SDK kit like LED blink, streamer, etc. All the working fine but not for this sample. I have tried all options to install drivers for the device but failed.


      What could be the reason? Kindly suggest.


      I have tested on the both machines: Windows 10, Windows 7, both system failed to install drivers for the Master and Slave FIFO devices (FX3 drivers not found message in the device manage while searching/updating drivers)