3 Replies Latest reply on Mar 8, 2018 9:08 PM by hima

    Updates on PSoC 5 Mass Storage Programming?

    DanielZimmerman

      I was hoping that I could use mass storage programming mode with the KitProg on a CY8CKIT-059 board to program the target PSoC 5. I'm using the board as the low-level controller inside a prototype robot, and re-programming it requires some inconvenient disassembly. The next revision of the prototype also has a Raspberry Pi connected to the outside world with either WiFi or wired Ethernet.


      The initial announcement of mass storage programming mode suggested it would be cross-platform (After I've tried and failed, I see in other materials that it probably isn't supported on Linux). I thought maybe I could plug the CY8CKIT-059 into the Raspberry Pi, copy the new .hex files over the network, to a holding folder on the Pi, and then copy them to the KitProg "drive" to update the robot firmware.

       

      I tried it and it doesn't work.

       

      Directly after mounting the KitProg (v2.18) mass storage device:

      After copying the .hex file to the KitProg mounted drive:

       

      However, I get the same error and failed programming with drag-and-drop in mass storage mode on Windows, and clearly the note states that mass storage mode only works with PSoC 4.

       

      So I'd be interested in knowing:

      • Is there any update or timeline for adding PSoC 5 support to KitProg mass storage mode so that it can be used on the CY8CKIT-059?
      • Is this definitely the problem here? (i.e. should it be impossible to use mass storage mode with a CY8CKIT-059 on Windows as well?)
      • Given that  the failure on Linux appears to be identical to the failure on Windows, will mass storage mode work for loading firmware to the device from Linux if PSoC5 support is added?

       

      Thanks,

      Dan