2 Replies Latest reply on Feb 2, 2018 1:51 AM by anks

    Code completion and "go to Definition" not working?

    andreas.kreuzer.ak2_1499391

      After two years I am just starting again with the PSoC Creator and some things are really bothering me.

       

      My Setup:

      - i5-CPU, 16GB RAM, SSD, 64bit Linux Host.

      - Win10 Enterprise 64bit in Virtual Machine with 8GB RAM and 4 CPU-cores in Virtualbox.

      - PSoC Creator  4.1 (4.1.0.2686)

      - CYC8KIT-042-BLE with CY8C4248LQI-BL583

       

      The problem is not the embedded, it is the PSoC Creator!

      The Code-completion does not work anymore. I tried to enable different features via Options --> Text Editor --> Inline Diagnostis and Autocomplete. But nothing that I can enable or disable there really changes anything! (Restarted PSoC Creator of course!)

      And if that was not already bad enough, the function "Go to Declaration F12" and "Go to Definition Ctrl+F12" is also not working! No error, no message, nothing happens!

       

      I also tried to install the PSoC Creator in a fresh Win7-Virtual machine, with the same results. Right after the installation the F12-function was initially working one time, but after reboot, or when I opened an old project, nothing worked any more.

      I was just thinking about ordering the new PSoC-6 with the BLE 5.0 functionality, but not with this performance!

       

      Is there anything I could do to improve the performance?

      Has anybody else recognized this behaviour?

       

      Thanks

      Andreas

        • 1. Re: Code completion and "go to Definition" not working?
          andreas.kreuzer.ak2_1499391

          Update on this topic:

           

          To investigate this bad performance I looked up an old PSoC Creator version from the time I started working with the PSoC.

          Two virtual machines: 8GB RAM, 4 Cores, usual settings for virtualisation.

          First: Win-7 professional 64bit, running on normal HDD, PSoC Creator 3.3, a simple project from that time. I opened up the project from that time, selected compile all and after it finished, I took the time to make a "Clean and Build all projects": Result 52seconds.

          Second: Win10 enterprise 64bit, running on SSD, PSoC Creator 4.1, a copy of the same project. I opened up the project and a first build gave me >20+ errors. I had to update some of the components, before being able to build the project. (Can that be disabled somehow???). After 5minutes of updating, the project built and I also took the time for a "Clean and Build all projects": Result 135 seconds!!!

           

          Why?

          I' m not really new to software-development and I really like the PSoC CPUs, but I would not recommend this IDE in a productive environment.

          Why do I have to update all components before I am able to build the project?

          Then I didn't install the KEIL-compiler, because I knew I would not use it. But I get an error on each build saying that the path to the binaries is not set!

          Maybe I am a little spoiled by the Android studio, that I used in the last few months intensively. But the management of sources for different platforms and different build-versions (flavors) is excellent there! And it runs natively on Linux, Mac and Windows.

          • 2. Re: Code completion and "go to Definition" not working?
            anks

            Hello,

            Why do I have to update all components before I am able to build the project?

            Ans:With each version of Creator , new version of  certain components gets incorporated.It is not compulsory to update all the components.

             

            Then I didn't install the KEIL-compiler, because I knew I would not use it. But I get an error on each build saying that the path to the binaries is not set!

            Ans:You can avoid that by this settings-

            1 of 1 people found this helpful