3 Replies Latest reply on Feb 25, 2018 11:15 PM by VasanthR_91

    psoc 4200 spi master clock speed >8 MHz problem



      I have a problem with getting spi master clock oversampling factor below 6.

      In the datasheet it claims I can set it to 2 if I have MISO pin removed.

      The only place I see that I can remove the MISO pin is by ticking the box under the SPI Pins tab, and click remove MISO.

      Unfortunately, as soon as I try to reduce the oversampling factor to less than 6 I get

      Invalid Parameter:
      Error 1: The SPI master oversampling factor must be in range 6 - 16.

      Any Idea of how I can get around this or have I completely misunderstood the section in SCB_P4_v4.pdf page 93

      For Master the minimum oversampling value is 6 (MISO presents) or 2 (MISO removed).


      Kind regards