1 Reply Latest reply on Jan 30, 2018 3:44 AM by ZhengbaoZ_96

    Debugging the BCM943362WCD4_EVB

      Hi,

      I'm using the BCM943362WCD4_EVB with WICED-Studio(WICED-SDK Version: Wiced_006.000.001.0005).

      I can't debugging when I received signal SIGTRAP.

      Could you tell me how to fix?

       

      1. Make snip.scan-BCM943362WCD4-debug download

      2. Run 43xxx_Wi-Fi_Debug_Windows

       

      on Console:

      [New Thread -268280318]

       

       

      Program received signal SIGTRAP, Trace/breakpoint trap.

      [Switching to Thread -268280318]

      0x0800c63a in _start () at WICED/platform/MCU/STM32F2xx/../../ARM_CM3/crt0_GCC.c:81

      81     __asm__( "   ldr r1, =link_stack_end\n"

        • 1. Re: Debugging the BCM943362WCD4_EVB
          ZhengbaoZ_96

          Hi  T-mat:

           

                Did you finish the debug configuration before running the debug process?

          On the left window please choose 43xx-Wi-Fi_Debug_Window

          1.  run the debugger configuration.

          2.  switch to Startup page, add below instruction into the area below Halt option:

           

          add-symbol-file build/eclipse_debug/last_built.elf 0x8000000

           

          3. in the same Startup page,  clear Run Commands area, default is like the phrase "stepi "

          4. switch to Common page,  click the "Launch in background "

           

          then run the debug process, thanks.

          2 of 2 people found this helpful