2 Replies Latest reply on Aug 24, 2018 1:20 PM by inaki.castillo

    Virtual COM ports broken after initially working on FX3 SuperSpeed Explorer Board

    rkodama_2818591

      I've been working through the example firmware in the book "SuperSpeed Device Design By Example".  I was able to successfully go through examples in Chapters 3 and 4 that use the micro-USB port in UART mode as a debug console.  I became very interested in the example "DualConsoleExample.img" from Chapter 5 because it seemed to offer a way to get a virtual COM port over the USB3 line without using the UART, because my project also requires SPI (which I guess conflicts with the UART).  Anyway, I installed the utility "USB Serial Configuration Utility" and followed the instructions in the book to configure channel SCB0 as I2C slave at 400kHz.  I tried loading the unmodified firmware "DualConsoleExample.img" and it loaded successfully.  But then I got no COM ports (supposedly I should get two, one for UART over the micro-USB and one for I2C over the USB3).  I repeated the steps a bunch of times, tried recompiling the firmware, enabling and disabling UART and I2C in all combinations, but I never got any COM ports.  I finally used the configuration utility to change SCB0 back to UART mode, but still no COM ports.  After this, the previous examples that just use the UART console over micro-USB no longer create COM ports either.  So, I would really like to learn how to make the I2C-based console work, but it would also be some progress to figure out how to get the UART mode console working again (reinstall drivers?).  By the way, in this whole process I don't see any orphan devices in the device manager.  I do see under "Universal Serial Bus controllers", three devices called "USB-Serial (Dual Channel) Vendor 1",  "USB-Serial (Dual Channel) Vendor 2",  "USB-Serial (Dual Channel) Vendor MFG".  Those devices claim to be working.  I'm using Windows 7 on a laptop with USB3 ports.

       

      Thanks,

      Richard