4 Replies Latest reply on Jan 4, 2018 5:45 AM by ltson36_2706041

    BCM943364WCD1_2 problem  on WICED SDK 5.2 and 6.0

    ltson36_2706041

      Hey

       

      As I am new in Cypress WICED SDK, so I have tried to test evaluation board with simplest examples from WICED.

       

      My board is BCM943364WCD1_e  module with BCM9WCD9EVAL1_6 development board.

       

      I have tested with several examples. The compilations and load firmware are OK.

      This is with example snip.scan

       

      But when I checked on serial terminal, it showed error and stuck at as follows:

      -------------------------------------------------------------------

      Starting WICED vWiced_006.000.001.0005

      Platform BCM943364WCD1 initialised

      Started ThreadX v5.6

      Initialising NetX_Duo v5.7_sp2

      Creating Packet pools

      -----------------------------------------------------------------------------

       

      I tested with other examples, for example, snip.apsta, it showed the same error.

      I have tested with WICED 5.2, 5.0, 6.0. All have the same problem.

      I have tried to debug, and it showed that  problem is at  the function:

       

      wiced_init()

       

      When I tested with other examples, for example snip.uart, which does not have wiced_init(), then it works fine.

       

      I wonder if you could show me what have been incorrect?

       

      Thanks a lot in advance

       

      Le