1 Reply Latest reply on Dec 5, 2017 4:08 AM by sudh

    CYUSB3KIT FX3 enumeration in Windows

    annamol_2415406

      Hi,

       

      We have purchased a CYUSB3KIT (FX3) development kit which we are planning to use for a video streaming application. My development environment is EZ USB suite and  Intel NUC windows 7 64 bit. The development kit is not getting enumerated in device manager as well as in control centre. As per the jumper configurations mentioned in kit guide, pg 35 we made all connections still there is no change. The PMODE settings are SW25.1 and SW25.2 are off and SW25.3 and SW25.4 are off and J96,J97 are connected between 2-3 and J98 is left open for USB enumeration.

      As of now, I have tried the following

      1. Modified jumper settings as per kit user guide
      2. Voltage levels were confirmed and VIO1 to VIO5 are giving 3.3V
      3. When powering via the external 5V DC jack, I have shorted J40,J47 and J53 connection is broken. Still there is no change
      4. Even after changing the cable provided along with the evaluation kit, there is no difference
      5. When trying to connect via an external Jlink Pro, target is getting detected and it measures 3.1V via GDB server, but connection fails
      6. As per instructions given in kit user guide, even tried running GDB debug configuration from Eclipse for ARM9, big endian, JTAG configuration. that stops session saying exception condition detected on fd0,error detected on stdin, quit (expect signal SIGINT when the program is resumed)

       

      It would be great if you can help us in getting the board up and running.