6 Replies Latest reply on Feb 15, 2019 12:23 AM by cxh930220_3839421

    The CYW20706 was not detected

    luis.cruz-ext_2918636

      Hello everyone,

       

      I just stated working with the CYW92076WCDEVAL evaluation kit and I'm following the "CYW920706WCDEVAL Kit Guide" in order to get the "hello sensor" demo working, but when I start the download ( demo.hello_sensor-CYW920706WCDEVAL download ) I get this message:

       

       

      Detecting device...

      ********* Detection Failure *************

      +------------------------------------------------------------------------------------------+

      | The CYW20706 was not detected. Verify that the device is connected, power-cycle if       |

      | necessary, and retry.                                                                    |

      | Please see Appendix sections in the Kit Guide for common com port problems.              |

      +------------------------------------------------------------------------------------------+

       

      Even though I'm able to detect both /dev/ttyWICED_HCI_UART0 and /dev/ttyWICED_PUART1.

      All the dip switches and jumpers are in their correct positions too.

       

      I've tried the make command "demo.hello_sensor-CYW920706WCDEVAL download UART=/dev/ttyWICED_HCI_UART0" with no success. That throws:

       

       

      Downloading application...

      ********* Download Failure *************

      +------------------------------------------------------------------------------------------+

      | Power cycle the CYW920706WCDEVAL board and retry.                                        |

      | If this problem persists, the serial flash on the board may be corrupted.                |

      | Please see Appendix D in the Kit Guide for recovery instructions.                        |

      +------------------------------------------------------------------------------------------+

      Download failed. This WICED platform of the SDK only supports download to 20706A2 device.

       

       

      So I tried to recover the board (steps described in Appendix D), but that doesn't work either.

       

      I know the board works because when I open a terminal on port /dev/ttyWICED_PUART1 I'm able to see the "hello sensor" traces (the board is shipped preloaded with that sample application).

       

      For more information, this is my setup:

      Ubuntu 14.04.2 LTS x86_64

      WICED Studio 6.0

       

      Thank you in advance

      Luis CRUZ