1 Reply Latest reply on Nov 10, 2017 7:00 AM by e.pratt_1639216

    PSoC Creator not working on my windows 7 machine. I've tried everything I can think of.

    thodg_2481266

      I have tried multiple versions of PSoC Creator, updating all components. Uninstalling all cypress sofware including all temp files registry orphans etc. I even tried uninstalling the C++ redistributable to for a pre-requisite check. Still no luck. This all works on my windows 10 laptop.

       

      Can any body give me an idea whats going on? This was working a few months ago just fine on this windows 7 machine. I have no idea what changed to make it stop working. The errors I am getting are as follows:

       

      pft.M0074: A (re)build is required to use the analog device editor. Unable to load the necessary information from the cyfit file. Partial/wrong data will be displayed until this has been resolved.

       

      The analog device editor loads data from the cyfit file to display its results. An error occurred attempting to retrieve this data. The editor will not work until the data is successfully retrieved. Attempt a (re)build to regenerate the cyfit file and fix the problem.

       

       

      sbd.M0033: The instance 'BLE', of component BLE_v3_30, contains an error. Unable to load symbol 'C:\Program Files (x86)\Cypress\PSoC Creator\4.0\PSoC Creator\psoc\content\cycomponentlibraryupdates\CyComponentLibraryUpdates.cylib\BLE_v3_30\BLE_v3_30.cysym' for component 'BLE_v3_30'. Parameter is not valid.

       

      Parameters: The most common kind of error in a component instance is that its configuration is incorrect, invalid, or unsupported. For example, the component may require a clock frequency that is not available given the current system clock configuration. Dependencies: If the component cannot be found try looking at the project's dependencies. Make sure that the "Component" depenedencies are correct.

       

      Is it possible this is a windows 7 file permission thing??

        • 1. Re: PSoC Creator not working on my windows 7 machine. I've tried everything I can think of.
          e.pratt_1639216

          Just be aware that some OS-es require rebooting after installing/uninstalling to ensure completion. This might be a cause/issue in your case.

          The analog editor is the Top Design part of the project if I'm correct, which means that you need to rebuild the whole project to open the Top Design file. If it is failing with that error on loading the project, then an option might be to try messing with the actual project files to see if you can get it to stop loading the "analog editor" on opening the project in order to build the project and fix issues with corrupt components/designs.There is a command-line interface/access to the PSoC Creator iirc, that might be able to run/work to get things going.

           

          Sorry I'm not much help, I haven't run into issues with the PSoC Creator on windows