4 Replies Latest reply on Nov 14, 2017 11:23 AM by e.pratt_1639216

    Cylakit cyble-022001 PSoC Creator not able to find BLE component. Path problem?

    thodg_2481266

      Back in June of this year I bought a Cylakit e-02 and installed all the software required to flash the beacon. At that time I was trying to get the kit to work as an eddystone beacon. I was provided a file called Simple_Eddystone_0.zip, which worked perfectly. Last week I bought 15 more beacons and was going to flash them with new URLs but the PSoC creator software is no longer working. I tried uninstalling. I tried re-installing. I tried everything I can think of. I am getting an error regarding the BLE component, but I do not know what to do about it or why it is appearing. Here is some info about the error:

       

      sdb.M0033: The instance 'BLE', of component BLE_v3_30, contains an error. Unable to load symbol 'C:\Program Files (x86)\Cypress\PSoC Creator\4.0\PSoC Creator\psoc\content\cycomponentlibraryupdates\CyComponentLibraryUpdates.cylib\BLE_v3_30\BLE_v3_30.cysym' for component 'BLE_v3_30'. Parameter is not valid.

       

       

      Parameters: The most common kind of error in a component instance is that its configuration is incorrect, invalid, or unsupported. For example, the component may require a clock frequency that is not available given the current system clock configuration. Dependencies: If the component cannot be found try looking at the project's dependencies. Make sure that the "Component" depenedencies are correct.

       

      I downloaded the software from the web page for the Cylakit.e-02. I tried the .iso file as well as the complete software dowload. They are all giving the same error.

      Any help would be greatly appreciated.

       

      PS I just reloaded all the software and the first error I see is this:

      Symbol file for instance "BLE" of component "BLE_v3_30" not found. Can't edit current instance. Check your search path.

       

      The files seems to be exactly where the program is looking for it.