7 Replies Latest reply on Nov 9, 2017 6:24 PM by jagir_2673086

    USB BLE dongle not working

    fredy.co.iy_1446786

      Hello, I bought a PSoC 6 BLE Pioneer Kit from Mouser Electronics. When it arrived at my home I tested it, the PSoC 6 board and EINK display are working really great, but the USB BLE dongle (cy5677) that came in the kit is not working. I don't know what to do, I already checked everything in the datasheets and technical documentation, but the computer doesn't detect the dongle, the power and status leds in the dongle board don't light, and the device is not listed in the device manager on windows 10. What should I do?

        • 1. Re: USB BLE dongle not working
          msur

          Hello fredy.co.iy_1446786,

           

          Please raise a support case with your order details and we will ship a replacement dongle for you.

           

          Regards,

          Meenakshi Sundaram R

          • 2. Re: USB BLE dongle not working
            fredy.co.iy_1446786

            Hello, thankyou for your support. I just raised the case with the order details.

             

            I must say, I was reviewing the dongle, it has a CYBL11573-56LQX as a target and a CY8C5868LTI-LP039 chip as a programmer.

            And since PSoC Programmer didn't detect the chip as a kitprog2, I came to the conclusion that the cy8c5868 chip must be a blank chip with no program to execute, so I used some soldering to put 5 cables in the SWD port of the PSoC 5LP in the dongle and used another Kitprog2 (from a cy8ckit-059) to upload the kitprog.hex located in:

            "C:\Program Files (x86)\Cypress\Programmer\KitProg.hex".

            IMG-20171028-WA0020.jpeg

             

            After that, I disconnected the kitprog from the cy8ckit-059 and connected the usb dongle. The computer detected the kitprog2 device but not as a usb dongle.

            So that could only mean that the CYBL11573-56LQX must also be blank.

            So I used PSoC Programmer to update the firmware of the kitprog, and the used PSoC Programmer to upload the hex file located in:

            "C:\Program Files (x86)\Cypress\CySmart\1.2\dongle\CY5677\BLE_4_2_Dongle_CySmart_256K.hex"

            into the CYBL11573-56LQX chip.

             

            after that I reconnected the usb dongle and windows detected the device, everything worked fine, I opened CySmart 1.2 and the usb dongle appeared in the supported devices list.

             

            Untitled-1.jpg

             

            So it apears to be a firmware issue that happened to me, I'm not sure if all usb dongles came like this, but if not, it could give a bad experience to someone who just bought a cypress product for the first time. though this could be a workaround to that issue.

             

            In the mean time I still haven't had the chance to test the dongle in an application, I haven't tried to stablish a ble connection so I don't know if other problems related to software or hardware might appear later. So I hope my case be followed up.

            1 of 1 people found this helpful
            • 3. Re: USB BLE dongle not working
              msur

              Hello fredy.co.iy_1446786,

               

              This is great And really sorry for the trouble. Though we do check the firmware in all our kits and dongle before shipping, it seems like this board was a miss.

               

              If you are able to program and use dongle, I believe there should not be any issue in the hardware. It most likely would have been a miss in our manufacturing test. I will follow-up on the case.

               

              Regards,

              Meenakshi Sundaram R

              • 4. Re: USB BLE dongle not working
                jagir_2673086

                Hello fredy.co.iy_1446786,

                Thank you for sharing this usefull info,

                I want to know that how you did upload kitprog.hex to target board using another kitprog programmer.I want to know it because i was working with PSoC 4 BLE Pioneer kit & recently some how accidentaly it stoped to detect in windows 7 PC. When i connect board with USB cable windows detects as a "kitprog" named storege device was connected but at device manager did not get com port for that board & earlier it was working fine.

                So i guess some how programmer get errased & by using the way you mentioned i may solve my problem also.

                • 5. Re: USB BLE dongle not working
                  fredy.co.iy_1446786

                  jagir_2673086, I was able to program the onboard kitprog of the dongle using another kitprog because the dongle has the SWD port connected to the psoc 5LP, as you can see in the first picture of my reply above, I put some cables on it... It was possible because that 5 cables are connected to the PSoC5LP, you can confirm this by looking in the schematics of the dongle. (I took the picture below from the pdf schematics avalable in cypress.com)

                  Untitled.png

                  That means that the SWD port in the dongle is actually a input and you can use any kitprog like the one that comes with the cy8ckit-059 to program the psoc5LP of the dongle, even you can change the program for it to act as any other enumerable USB with BLEm I think that was designed for... Flexibility.

                  1 of 1 people found this helpful
                  • 6. Re: USB BLE dongle not working
                    fredy.co.iy_1446786

                    jagir_2673086 BUT!!!!!.... my answer above was just for your question of how I did it...

                    AND your problem as I understand, is not about the firmware being somehow deleted... It is not a problem nor an error actually, your kitprog is completely fine and is working in "mode 2", you see, all kitprogs have 2 main modes of operation.

                    Mode 1: using the usb bus to connect to psoc creator or psoc programmer an so, the typical mode...

                    Mode 2: as storage device, you can actually see the kirprog as a storage device in the computer, like this:

                    Untitled.png

                    If this is your case, you just need to switch it back to mode 1... the way to do that differs between kitprogs, in the psoc 6BLE board you just need to push a button (SW3 to be precise)... in other kitprogs you just need to plug the kit prog to the pc and press for a seconds the RESET button of the kitprog. Press the reset button for other seconds and it will switch modes again. In my kitprog the status light is ON when the kitprog is in mode1 and is blinking when it is in mode 2. I don't know wich of those ways the kitprog in the psoc 4 ble is done so just check the technical references of that yout kit.

                     

                    Oh, and by the way, if you were wondering, Yes, you can sitll program the target device with te kitprog in mode 2, you need to place the HEX file inside the "storage device", of course it is your responsability to place a correct HEX file for the target device that normally the psoc programmer would do for you... That mode is mainly for IDEs that just generates the HEX file. mmm, The whole topic of the programming modes is large so strongly recommend you to not to take my words for facts and check the cypress documentation yourself for a better understanding, and if you need help, feel free to ask anything.

                     

                    I hope I had helped you, please tell me if you were able to solve your problem.

                    1 of 1 people found this helpful
                    • 7. Re: USB BLE dongle not working
                      jagir_2673086

                      Hello Fredy,

                      Thank you so much for sharing this info with me and sorry for the late reply it was an extremely busy week.

                      You are absolutely correct, My board was in mode 2 which is Mass storage device & Indication is status LED blinking with a slow blinking rate.

                      I got this info from kitprog User guide it is very clearly defined

                      I was able to move it back to programmer mode by press & hold SW1(Reset switch) on connecting cable to the USB port.

                      Yes, I know that you have connected SWD cable to programme BLE Dongle externally.

                       

                      Thank you.fredy.co.iy_1446786