4 Replies Latest reply on Oct 30, 2017 6:56 AM by jim.yin_2467326

    ADC_SAR_SEQ

    jim.yin_2467326

      Hi All,

      I use CY8CKIT-059 prototyping kit. When I tried to use the component of  ADC_SAR_SEQ to receive external analog signals, I met with trouble.

      I copied my setup and the problem blow.

       

       

       

       

       

       

       

       

       

       

       

       

       

       

       

      When I build the program, it shows that "vdac_ref" on ADC_SAR_SEQ_v2.0 is unconnected. I am not sure how to connect this hidden pin. I have to connect it to a DAC output pin?

       

      Thank you in advance.

       

      Jim

        • 1. Re: ADC_SAR_SEQ
          user_78878863

          This is just an informational message (as seen by the icon). So you can safely ignore it.

          • 2. Re: ADC_SAR_SEQ
            jim.yin_2467326

            Thanks very much for your response. You mean that I can ignore this error message? in another words, this message is a bug?

            • 3. Re: ADC_SAR_SEQ
              user_78878863

              tl;dr: Yes. No.

              Yes, you can ignore this message. It neither an error nor a warning, its purely informational.

              No, I don't think its a bug, it actually tells you the truth: Vref is actually _not_ connected to a terminal - you are using internal Vref. (So this message should not appear when you are using external Vref, or even when using buffered Vref [which is preferred anyway])

              Cypress might consider it a bug that the write internal (debug?) messages to the console log.

              The only bug here might be that the signal seems to named wrong: its _vdac_ref_ whereas it probably should be _vadc_ref_.

              • 4. Re: ADC_SAR_SEQ
                jim.yin_2467326

                Thanks again and again for your help.

                One more thing is that I tried to use three Wave DAC8, but some one no output and some output is clamped, I checked everything and they seem good.

                 

                Regards

                Jim