1 Reply Latest reply on Oct 20, 2017 5:08 PM by mifo

    imx6ul board with Murata 1dx wireless module

    inyourface

      Hi,

      We are facing a problem that Wifi is slow when bluetooth is scanning. Following are the details.:

       

      Murata wireless module : LBEE5KL1DX-883

      I am using the IMX6UL EVK board with Murata 1DX module (in-band) and doing the following:

      • Using the downloaded fsl-image-validation-imx-x11-imx6ul7d.sdcard SD card image from NXP's site
      • Applied the Murata binary patch by copying the files over the image root, and copying DTB files into the boot partition (this happens with or without those files). Patch link: wireless.murata.com/RFM/data/murata_quick_start_guide_linux.pdf
      • setenv fdt_file imx6ul-14x14-evk-btwifi.dtb in u-boot
      • Using gpio export on GPIO 508 in sysfs in combination with hciattach "/dev/ttymxc1" "bcm43xx" "3000000" "flow" to bring up bluetooth
      • Using sysfs to modify bcmdhd firmware and nvram path and wpa_supplicant to bring up wifi

      I am able to bring up bluetooth and wifi. Bluetooth and wifi performance is perfect while both are not in use. However, while scanning with bluetooth using the provided BlueZ stack or "hcitool lescan", pings start fluctuating and going up to 2+ seconds and experience packet loss. Transfers are brought to a halt. For example SCP-ing a 5MB file takes 5-6 seconds normally, but while BT scanning it may take 10 minutes if I'm patient enough to wait or if connection doesn't drop. Ifconfig reports no TX/RX errors. The wifi connection is pretty much unusable during bluetooth scan.

      • As soon as I stop the scan, all transfer speeds are back to normal

      Some oddities and things we've tried

      • The address of both Murata EVK modules that we have, and all our custom boards have the same BT address 43:43:A1:12:1F:AC. The custom boards have "engineering sample chips", but I suspect that they wouldn't have programmed in BD Addressees on these 1DX EVK modules (purchased through Digikey) or even engineering samples. That makes me think that we're not using a correct firmware even though hciattach reports loading /etc/firmware/BCM43430A1.1DX.hcd successfully.
      • I've tried using the type1dx_nvram.txt from the murata's 1DX support site, and the issue is still there.
      • We also have custom boards based on imx6ul and 1DX that have the exact same problems.

       

      This is causing an issue with our code that is trying to send scan results over the internet and our web applications running on the board's browser/display.

       

      Any thoughts on what is going on here or what I could be doing wrong?

       

      Regards,

      Shu