13 Replies Latest reply on Dec 8, 2017 6:26 AM by josac_2926041

    SDK-3.7.0-7 Eclipse IDE not starting

    VoAn_2766281

      Hi,

      I installed WICED SDK 3.7.0 on Windows and tried to run Eclipse IDE but it failed with the error, anyone know how to fix this ?

       

      Caused by: java.lang.ClassNotFoundException: org.eclipse.swt.SWTError cannot be found by org.eclipse.ui.workbench_3.106.1.v20140827-1737

        at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:432)

        at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:345)

        at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:337)

        at org.eclipse.osgi.internal.loader.ModuleClassLoader.loadClass(ModuleClassLoader.java:160)

        at java.lang.ClassLoader.loadClass(Unknown Source)

        ... 41 more

        • 1. Re: SDK-3.7.0-7 Eclipse IDE not starting
          VinayakS_26

          Hi,

          Do you have Java Runtime environment(jre) installed in your system? If installed, make sure that if eclipse ide is 32-bit then JRE should also be 32-bit version.

          • 2. Re: SDK-3.7.0-7 Eclipse IDE not starting
            VoAn_2766281

            Sure I have JRE installed. Tried IRE 1.6, 1.7, 1.8 with the same results...

            • 3. Re: SDK-3.7.0-7 Eclipse IDE not starting

              I have the same issue. I have Java 1.8.0_152 32-bit loaded as well as trying to load the 'eclipse_win32.exe' file. Forget about the 64 bit version, that one I gain no progress on getting to work. I've tried changing the System Environment Variable for PATH to the 32 bit java /bin folder with no luck also. The log is riddled with java errors but I cannot tell what is not working since all debugging tells me java is working properly. running the command 'where java' in a command prompt results in the correct 32bit java location. java -version also shows the correct info. I'm lost.

               

              Funny thing is the WICED Studio 6.0.1 runs just fine. What gives?

               

              Here is the eclipse_win32.ini file's contents:

              -refresh

              -startup

              plugins/org.eclipse.equinox.launcher_1.3.0.v20140415-2008.jar

              --launcher.library

              plugins/org.eclipse.equinox.launcher.win32.win32.x86_1.1.200.v20140603-1326

              -product

              org.eclipse.epp.package.cpp.product

              --launcher.defaultAction

              openFile

              --launcher.XXMaxPermSize

              256M

              -showsplash

              org.eclipse.platform

              --launcher.XXMaxPermSize

              256m

              --launcher.defaultAction

              openFile

              --launcher.appendVmargs

              -vmargs

              -Dosgi.requiredJavaVersion=1.8

              -Xms40m

              -Xmx512m

              • 4. Re: SDK-3.7.0-7 Eclipse IDE not starting
                MichaelF_56

                Adding mady grsr rroy riya vnak from the applications team.

                 

                Why are you doing an initial install with SDK 3.7 (released Summer 2016)?

                • 5. Re: SDK-3.7.0-7 Eclipse IDE not starting

                  I am entering this WICED environment as a newbie. I have no clue what it is I am doing, and I understand a learning curve is involved, but this is ridiculous. Does Studio include the SDK? Is the correct process to install the SDK via Studio? I am confused.. There is no installation documentation available in the downloads section. I was assuming Studio and the SDK IDE were two different tools.

                   

                  I am extending some work that a contractor has done for us and that SDK is what they were using and recommended it for me to install. I wasn't sure if Studio 6.0.1 would be compatible with the work he's already done. I am only interested in the wl tool and manufacturing test portions though. If I can accomplish the same thing with Studio I can try with that, I still don't see why the SDK IDE won't launch though.

                  • 6. Re: SDK-3.7.0-7 Eclipse IDE not starting
                    MichaelF_56

                    If my memory serves me correctly, 3.7 had an issue with the JRE installed as it required a very specific version of the JRE, which wasn't always the latest.  These types of installer issues have since been debugged in newer versions of the SDK.

                     

                    Do you have a product based on SDK 3.7,or was work started, but no product in production that needs to be upgraded to 6.0.1?

                     

                    As far as getting up to speed, you may find these training videos useful: Wiced Training Videos & Getting Started

                    • 7. Re: SDK-3.7.0-7 Eclipse IDE not starting

                      I was able to load the SDK into Studio as a project. I will play with this route.

                      1 of 1 people found this helpful
                      • 8. Re: SDK-3.7.0-7 Eclipse IDE not starting

                        So for this issue I resolved it by installing the latest WICED Studio (6.0.1 at this time), then importing the unzipped "WICED-SDK 3.7.0-7 .7z" Source files into Studio. In Studio, navigate to File-->Import, then select the root folder of the extracted SDK files. Import the project into your work area as to not affect the source files in case you need to roll back.

                         

                        I wanted to create the mfg_test application and run it, so I created a new build string in the Make Target window to include the components I needed. In my case I used the string: test.mfg_test-ThreadX-NetX_DUO-BCM94390WCDS JTAG-Olimex_ARM-USB-TINY-H download run

                         

                        Running that build string loaded the program onto my TiWi-C-W module from LSR which uses the BCM4390 SoC.

                         

                        This app works with the included wl4390A1.exe over UART

                         

                        However, I am running into an issue where some of the batch script commands fail due to the COM port being open. I think the COM port isn't closing fast enough by the time the script executes the next command, even with TIMEOUT delays in between commands. I will start a new thread on this issue if a search comes up empty.

                        1 of 1 people found this helpful
                        • 9. Re: SDK-3.7.0-7 Eclipse IDE not starting

                          Update: Adding logic to the batch script due to COM port open issues corrected the problem. I attached my mfg_test script that will retry a step if that step resulted in any error returned.

                          • 10. Re: SDK-3.7.0-7 Eclipse IDE not starting
                            user_2199751

                            I have a question on your comment on importing the 3.7.0-7 source.

                            As I go to file and select import, I can see a window asking import source as below. Can you tell me what to select from this?

                            Thanksimport.JPG

                            • 11. Re: SDK-3.7.0-7 Eclipse IDE not starting

                              You want to select General-->Existing Projects into Workspace

                              1-Import_General.jpg

                               

                              Then you want to browse for the project folder (WICED-SDK-3.7.0-7 or whatever SDK you want to load).

                              2-Browse_for_Project.jpg

                              Then you want to click the check box next to the project in the window and set your options for importing. I wanted to copy everything to my work area so I have a copy of the source files to revert back to if needed, so I chose the option to Copy projects into workspace.

                              3-Import_Options.jpg

                              Click finish and you will see the project loading. When it is done you should see this in Studio:

                              4-Imported_Project.jpg

                              2 of 2 people found this helpful
                              • 12. Re: SDK-3.7.0-7 Eclipse IDE not starting
                                user_2199751

                                Hi

                                Sorry to keep asking for a help but I tried your procedure I could not find the project.

                                In your case, previous versions of Wiced IDE (3.x.x) were installed before you install Wiced studio?

                                or do I have to manually create project?

                                • 13. Re: SDK-3.7.0-7 Eclipse IDE not starting

                                  No problem, happy to help.

                                   

                                  In my case, I started with nothing. I tried to install WICED SDK 3.7.0-7 IDE Installer but kept getting a java issue. Rather than try every version of java to get that to install, I just installed WICED Studio (latest version) since this seems to be the most up to date IDE.

                                   

                                  Then I downloaded the SDK source files from here: WICED SDK 3.7.0-7 .7z Source files

                                  I extracted these source files to C:\WICED (you can extract them wherever you want)

                                   

                                  To import it, I pointed to the newly created folder C:\WICED\WICED-SDK-3.7.0-1 and it imported the SDK into Studio (2nd picture in my post above). Just point to wherever you extracted the SDK source files to. It doesn't have to be C:\WICED

                                  1 of 1 people found this helpful