4 Replies Latest reply on Sep 20, 2017 12:25 AM by user_219011237

    Autocomplete function not working.

    user_219011237

      Good day.

       

      A weired problem regarding autocompletion here:

      I got 2 laptops and running PSoC Creator 4.1 in same VM config (virtualbox 5.1.22)

      on both machinces. However, the autocompletion function works not at all in

      one of them, even I have all options checked in

      [Tools]->[Options]->[Text Editor]->[Inline_Diagnostics and Autocomplete].

       

      I tried to (all in the VM) remove guest addons, w/ or w/o D3D support,

      upgrade to 5.1.26 or uninstall then reinstall back 5.1.22, all efforts in vain.

      The other one kept in 5.1.22 still has autocompletion functioned perfect.

      If anyone has ever encounter similar problem and/or know any clue to it,

      please kindly let me know.

       

      Thanks,

      Carl

        • 1. Re: Autocomplete function not working.
          anks

          Have you tried reinstalling PSoC Creator4.1

          • 2. Re: Autocomplete function not working.
            user_219011237

            Yes, uninstall, reboot, then reinstall, reboot. The problem remains after that.

            Now I got both setups (2 VMs in the opening post) having this issue,

            even after another current VM version (5.1.28).

             

            BTW I have tried guest addon on and off, d3d support normal (win7 aero support) and

            basic (win7 aero not support).

             

            I've noticed that the once being normal one started being abnormal after a VM crash.

            However, I cannot do anything to that even a completely project rebuild (clean and build

            all project within).

             

            Is there still anything I missed and should try as well? Tried every config I could imagine

            and got nothing is quite frustrating..

             

            **Edit: 20170920-0957**

            Just found someone had autocomplete dysfunction in the forum as well, though he

            still got something to display, instead of nothing out in my case:

            PSoC Creator 4.1: Code editor / AutoComplete feature not showing all contens

            • 3. Re: Autocomplete function not working.
              anks

              One of the following Windows platforms is required:

               Windows 7 and Windows 7 SP1 (32- and 64-bit supported)

               Windows 8 and Windows 8.1 (32- and 64-bit supported)

               Windows 10 (32- and 64-bit supported)

               Mac OS X El Capitan on VMware Fusion 8 running Windows 8.1

               Mac OS X El Capitan on Parallels Desktop 11 running Windows 10

               Ubuntu 15 Linux with Oracle VM VirtualBox running Windows 10

              • 4. Re: Autocomplete function not working.
                user_219011237

                anks, thanks for the prompt replying,

                 

                Excuse me for not being clear enough in environment specification:

                I am currently running Windows 7 SP1 64-bit up-to-date in Oracle (VM) VBoxs, in Windows 7 SP1 64-bit up-to-date host, over 2 laptops.

                Each of both laptop have 4GB (VM) / 16GB (physical) RAM.

                 

                Other version information had been informed in previous posts.

                 

                If there's something missed, that might help identifying problems, please tell me.