1 Reply Latest reply on Sep 5, 2017 1:59 AM by user_36650440

    Unable to enter debugger using Cypress example code on CY8CKIT-042BLE

    user_36650440

      On building a simple program with Creator V4.1 update 1, Microsoft Windows NT 6.1.7601 Service Pack 1 (windows 7) I get:
      "Error: dbg.M0023: There was an error while programming the device: failed to reacquire the device"
      In the past this has always ended up being a problem with the optimisation level chosen for the project. I have switched everything to "Debug" that I can, removed all optimisation and ensured that all the programmer firmware is up to date.
      But the problem still arises.

       

      I raised this as a technical query but the query was cancelled (and no email telling me so was ever recieved......)

        • 1. Re: Unable to enter debugger using Cypress example code on CY8CKIT-042BLE
          user_36650440

          OK solved.

           

          The Cy8CKIT-042-BLE was in some form of USB storage device mode. I noticed this when using trying the simple program back on the BLE kit having proved it could download and debug on the -042 varient.  When programming it from the programmer (to eliminate any effects from creator) the port selection ID looked odd (not prefaced with "KitProg"). I found the device was registered as a USB drive. The only file on the drive contained instructions on how to remove the mode and return the kit to normal (5 second reset). I would ask Cypress to improve the information on gthis mode in the main documentation. The lack of adequate docyumentation just cost me 1.5 days effort.......................

           

          I