3 Replies Latest reply on Aug 24, 2017 6:09 AM by hakan_1946346

    Cannot acquire device

    hakan_1946346

      Hello,

       

      I am using CYBLE222014 chip and MiniProg3. I want to flash the chip using MiniProg3 SWD(5pin), but i cannot toggle power of the chip. I am getting the error below:

       

      WARNING!  | Power was not toggled! Please unplug and replug the programmer into the USB port or Toggle the power again

       

      i tried to replug but did not work.

       

      I am getting same error when using EzBLE Module. If i connect UART0 cables, it cannot toggle power. If i remove the UART0 cables, it can toggle power.

       

      Edit: More Information

       

      I supply power the chip via battery,

      My Programmer configuration is:

       

      Programming mode: reset

      Connector: 5p

      Protocol: SWD

      Voltage: 3.3V

       

      Status Voltage changes between: 3480 - 3500mV

       

      On right corner of the window, status shows connected and powered. When i try to flash i get new error message (i cannot still toggle power via button)

                                                                     | FAILED! PSoC device is not acquired! Check connection of the chip to the programmer

                                                                    |

      Please, check the following items:

                                                                    |  - the connection between the programmer and the PSoC;

                                                                    |  - the correct programming protocol is selected;

                                                                    |  - the correct connector option is selected.

       

       

      EDIT 2: I think I started to understand the programmer. I am using external power supply so i cannot toggle the power using programmer. I need to use it in Reset mode.

      But still programmer can not acquire the device.

       

      EDIT 3: Chip is working. I can scan the chip via Smart Phone.

       

      Thanks in advance,

      Mert