3 Replies Latest reply on Jan 26, 2010 10:28 AM by jim.desilva.2

    Cypress Creator 1 error

    jim.desilva.2
              Creator tells me that the version of Programmer is incompatible and to update to ver .604 or later. I have version 3.10.1.616 installed. Creator does not see attatched device when I try to program. I tried a repair install of Creator but problem remains. Cypress update shows no updates available. Creator was workng and I'm not sure why it stopped. Does the binary upload for the driver station prevent further accress to the PSoC module ?   
         
      PSoC3 module accepts program from programmer and First driver station app. can see and use device but I can't load any of the sample programs from the kit.   
         
      Also, do you know if the Creator or Labview source files for the driver station app. are available ? We want to learn how to access the module from labView.   
         
         
      Thanks for your help.   
         
      Jim   
      Team 1983   
        • 1. Re: Cypress Creator 1 error
          jim.desilva.2
                  Hello Jim,   
             
          If you have any instance of PSoC Programmer open, please close it. Disconnect and reconnect miniprog3 from/to the machine.   
          Go to debug menu in PsoC Creator and then click on 'Select Debug target'. Do you see miniprog there? If it is there, click on 'port Acquire' and check if it gives option to connect to the device. If you get connect option to connect, click on that and after that close the pop up window.   
             
          If it does not work, please try to reboot you machine and try above mentioned things again.   
             
          If it gives some error, please attach the screenshot of error.   
             
          Best regards,   
          Sachin   
          • 2. Re: Cypress Creator 1 error
            jim.desilva.2
                    Hi sgup,   
               
            I tried what you suggested with no luck. The device I am using is the First touch starter kit. The error message that I am getting is in the output window of Creator 1 beta 4. It is too big for a screen shot so here is a cut and paste version.   
               
            The installed version of PSoC Programmer is incompatible with this software. Update your programmer to PSoC Programmer 3.10 Build 604 or later.   
               
            No targets are listed in the select target window.   
               
            So far I have done repair installs of both Creator and programmer and run the update manager. Maybe I need to do a remove and install.   
               
            For now I just leave the Programmer open and use it to flash the device instead of using the function from within Creator.   
               
            Thanks for your help.   
               
            Jim   
            • 3. Re: Cypress Creator 1 error
              pkx

              Jim,

                 

              I believe we met at the finals a couple of years ago and organized a workshop in the Seattle area? The First Touch Starter kit has been obsolete for a two years and is no longer supported. If you download and install an earlier version of Creator like the one on the CD that was supplied with the FTK (and turn off updates), you should still be able to use that kit. However we recommend that you use the CY8CKIT-049 kit that was supplied with the 2015 KOP or the CY8CKIT-059 kit that is (or will be) available on the FIRST Choice site hosted by ANDYMARK . 

                 

              We have also added a post on how to use the -059 kit in this forum. 

                 

              Regards,

                 

              Patrick Kane