9 Replies Latest reply on Apr 24, 2012 3:58 AM by masayuki.hasegawa

    cy_boot update

    stoyan.karanfilov.2

      Hi,

         

      Yesterday I have updated PSoC Creator.  When I load the project I have worked on, only cy_boot apears to be newer - from ver 2.2 to 2.21. I have updated it. I made some changes and since then there are only troubles with stuff, that worked before. I am not pasting any code here, because it is very long, but operators like:

         

          char outputStr [3] [20];

         

          float input [3];

         

           ...

         

          sprintf (outputStr [i], "%.3f", input [i]);

         

      seemed to mess up the mem data.

         

      I tryed:

         

            sprintf (outputStr [i], "%.3f", 123.456);

         

      and it was the same. Then I tryed:

         

           char test [20];

         

           ...

         

           sprintf (test, "%.3f", 123.456);

         

      same story.

         

      It is working fine with %d, but with %f is not. I debug it several times wondering what's wrong with the code, and I found nothing. Then I get the backed up project (before the update). I started it up, it asked for an update and I choose no. The project runs smooth. The very same project - I loaded it again, and it asked again for update (I didn't mark it previous time as up to date). I made update. I check explicitly what exactly is going to e updated. Compile it, run it - data was messy. 

         

      I spent almost a day chasing gosts. Can you please advise waht's going on. 
       

         

      Thanks,

         

      Stoyan Karanfilov