6 Replies Latest reply on Apr 5, 2014 10:17 AM by user_1377889

    PGA: No signal setting any gain other than 1

    scott.griepentrog

      I set up the example PGA and was encouraged to find that my audio signal (~25mv p-p) was passing through cleanly with no noise.  I need to set the gain higher before going onto the next step, but found that changing main.c to set any other gain than PGA_1_GAIIN_01 would cause the audio to stop completely.  Am I doing something wrong or is PGA unable to handle low amplitiude imput signal?

        • 1. Re: PGA: No signal setting any gain other than 1
          user_1377889

          It would be helpful (as always ) when you upload a complete workspace bundle here, so that we all can have a look at.

             

          How is your signal fed in? Is there a V bias which gets amplified too?? Or are you using a capacitive coupling that would result in negative voltages on the input and needs to be shifted with a R-network???

             

          Picture of your input-schematic would help us.

             

           

             

          Bob

          • 2. Re: PGA: No signal setting any gain other than 1
            content.librarian

            Is this a typo in your original post and/or your code ? PGA_1_GAIIN_01

               

             

               

            Should be PGA_1_GAIN_01

               

             

               

            Regards, Dana.

            • 3. Re: PGA: No signal setting any gain other than 1
              scott.griepentrog

               Sorry about the typo.

                 

              I'm using the PGA_ExampleProject01 from psoc creator 3.  Nothing modified except the gain value.  It's P0[2] in, with P0[3] out.

                 

              My input connection is a microphone (actually, a speaker being used as a microphone) with ground connected to VR on the devboard, and positive connected directly to the P0[2] input.

                 

              My output is going to a RS 277-1008 battery powered amplifier, with VR as ground and P0[3] as the output.

                 

              When I first run the unmodified PGA example, I get audio carried across between P0[2] and P0[3], visible on scope and audible in amplifier output.

                 

              Change the Gain to anything other than the 01 that comes in the example results in no audio.

                 

              Audio is very low amplitide - at most 25mv p-p.  I'm using this particular rig because it closely simulates a guitar output, which is what I want to pre-amp before doing other signal processing with the PSoC.  I'm hopeful that I'm just doing something wrong, as opposed to these signals being too low level to connect directly to the micro without a separate preamp.

                 

              I'm attaching a screen grab of the pga arrangement from the example for clarity.  Not yet sure about workspace bundle yet, last I played with PSoC Creator was back when PSoC 1 had just come out.  It's a lot more powerful now.

              • 4. Re: PGA: No signal setting any gain other than 1
                scott.griepentrog

                I realize my description of my connections may be a bit confusing, so I've drawn it out (attached).

                   

                I made a presumption that the VR (about 1.2v) would be a good reference, that could be wrong.  I also presumed I could skip capacitive decouple on the input since all my gear is battery powered (amplifier, scope) and ground can be whatever I connect it to.

                • 5. Re: PGA: No signal setting any gain other than 1
                  scott.griepentrog

                   Okay - problem solved.

                     

                  I realized the vref was set to internal, changed that to external and connected it to my common analog ground AND the VR pin as a stable voltage and wham the 16 gain setting works great!

                  • 6. Re: PGA: No signal setting any gain other than 1
                    user_1377889

                    Fine to hear that it works now for you!

                       

                     

                       

                    Bob