I noticed that in the file ./Wiced-Smart/bsp/inc/20732mapa1.h, the naming convention for the defines is a bit clumsy.
Especially defining the word "version" line 225:
#define version (*(volatile unsigned int *)version_adr)
I had compiling issues because of using a structure member called "version".
This is not a bug but I just wanted to inform you of the possible issues it could lead to.