1 2 3 Previous Next 62 Replies Latest reply on Oct 31, 2013 5:50 PM by user_14586677

    CY8CKIT-042 PSoC 'ES' ?

    james.jackson

       Just a quick question.

         

      I am using one of the new CY8CKIT-042 PSoC4 Pioneer Kits. 

         

      There are some things that I am not able to get working on it (like a simple 16x2 LCD display), even though I have tried everything that I know to try.

         

      I am no expert using Creator (3.0), or the PSoC, or the 'kit', but I am really reaching the end of things to try.

         

      As a last resort, I got out my magnifier and read the Part Number on the PSoC4 chip. It is...

         

      CY8C4245AXI-483ES

         

      My question... What does the 'ES' stand for?

         

      If it is what I think it means, then I am using an 'Engineering Sample' part on this board. (Or trying to use one.)

         

      Can someone shed some light on this? If it _is_ an Engineering Sample (and I have purchased two (2) Pioneer Kits - both have 'ES' parts on them), then this may explain why I am having difficulties.

         

      Thanks.

         

      James

        • 1. Re: CY8CKIT-042 PSoC 'ES' ?
          user_14586677

          ES is engineering sample. My kit, also is ES labeled.

             

           

             

          Post an archive of your project for forum to take a look at, under file menu in Creator.

             

          When you post don't use Chrome.

             

           

             

          I assume you are using a 44780 controller based LCD ? Part number, datasheet also helpful.

             

          And how you have it connected to kit.

             

           

             

          Regards, Dana.

          • 2. Re: CY8CKIT-042 PSoC 'ES' ?
            james.jackson

            Before I upload my code, perhaps someone could verify if they have gotten a 16x2 LCD display to work on the Pioneer Kit.

               

            I am using the provided LCD component, and have it hooked up to the only contiguous port available on the Pioneer kit - P2[0-6].

               

            I get nothing on the display.

               

            The only thing that works is the potentiometer that makes the display darker when adjusted.

               

            Thanks.

               

            Regards,

               

             

               

            James

            • 3. Re: CY8CKIT-042 PSoC 'ES' ?
              user_1377889

              A search for "Pioneer LCD" at the top of this page reveilled at least this thread www.cypress.com/ which at this time I could not follow since the target server seems to be down temporarily.

                 

              So there ARE Pioneer kits with a connected LCD.

                 

               

                 

              It is quite usual habit to sign the first chips on the market as "ES" since the specs are out and the users may come up with problems they have found so far which then would be written down in the Errata-sheet. As you can see (or rather: as you cannot) there is no errata for the PSoC4 yet, indicating that the Cypress engeneers did a comparable good job (this time).

                 

               

                 

              So lean back and relax. When something is not working it might be your fault, it might be hte system's fault. But I estimate the chances are 95 by 5.

                 

              What about posting your complete project? Some of us already asked for that. Fastest way to get help here.

                 

              Bob

              • 4. Re: CY8CKIT-042 PSoC 'ES' ?
                james.jackson

                Bob,

                   

                Thanks for the input. Yes, I saw the First 50 projects thread, and got my hopes up that I had a solution in that. I spent a lot of time (about 15 to 20 minutes) downloading a huge Zip file.

                   

                I then unzipped it, and looked for that one 'Character LCD Display' program, that turned out to be ... not there. What is being used is some graphic touch screen display, or other non-related device.

                   

                I, too have experience with 'ES' chips, I.E. the PSoC 3 - and am therefore leery of anything from Cypress with 'ES' in the part number.

                   

                I will post my code later today, but want to review it one last time, and clean it up a bit, which may also help me find a solution on my own.

                   

                As for Dana's comment about using a Hitachi 44780 - these haven't been made in a while. I am using a compatible part that is newer - and runs at 3.3 volts. Unless she (or anyone else) has a part number of an approved LCD display that I can use.

                   

                Regards,

                   

                James

                • 5. Re: CY8CKIT-042 PSoC 'ES' ?
                  user_14586677

                  A 44780 compatable part works with the LCD Character component.

                     

                   

                     

                  You have wired up to your display a pot for contrast control ?

                     

                   

                     

                  Regards, Dana.

                  • 6. Re: CY8CKIT-042 PSoC 'ES' ?
                    james.jackson

                    Dana, I am using an LCD Display with a ST7066U controller - which I have researched, and I believe is compatible.

                       

                     

                       

                    Yes, I have the Potentiometer hooked up, and so far, that is the only part of the LCD that _is_ working. I get a solid black bar when I turn the pot all the way to one end of travel.

                       

                     

                       

                    Looking further in to this - I will post more on this later after I have run more tests.

                       

                     

                       

                    Regards,

                       

                    James

                    • 7. Re: CY8CKIT-042 PSoC 'ES' ?
                      user_14586677

                      Take a look at this, some comments might be relevant -

                         

                       

                         

                      http://www.element14.com/community/thread/25277

                         

                       

                         

                      and this -

                         

                       

                         

                      http://www.cypress.com/?app=forum&id=2492&rID=75707

                         

                       

                         

                      Regards, Dana.

                      • 8. Re: CY8CKIT-042 PSoC 'ES' ?
                        user_14586677

                        James, first link in prior post worthless, its a SPI interface to LCD,

                           

                        but second link might still be of value.

                           

                         

                           

                        Just as an aside, you issued a LCD_Start() to the component ? I have forgotten in

                           

                        the past to do that myself.

                           

                         

                           

                        Regards, Dana.

                        • 9. Re: CY8CKIT-042 PSoC 'ES' ?
                          james.jackson

                          Dana said, "Just as an aside, you issued a LCD_Start() to the component ? I have forgotten in the past to do that myself."

                             

                           

                             

                          Dana, yes, I did an LCD_Start.

                             

                           

                             

                          I also spent the entire day, wiring up a different LCD Display. I ran this display using the program, and am getting the same results. Nothing on the display.

                             

                           

                             

                          I have checked, double-checked, triple-checked, quadruple-checked (are you seeing a pattern here?) the wiring to the LCD. It is per the documentation for hooking up the LCDs. I have it correct, per the documentation.

                             

                           

                             

                          I have attached the Archive of the program that I am using. (I hope it is attached...)

                             

                           

                             

                          I have yet to hear from anyone who has personally wired up an LCD display to the PSoC4 Pioneer Kit, and gotten it successfully to run.

                             

                           

                             

                          I do not need 'example code', I believe that I have looked up a good example that was included with the Pioneer Kit, and copied much of that to my program.

                             

                           

                             

                          In fact, I programmed the example code into the Pioneer Kit, and it does not produce a display on the LCD either.

                             

                           

                             

                          All I know is that I have been working on this - just the display - for over two weeks now. If I cannot get it to work, I am abandoning the PSoC4 as a viable microprocessor for my next project, and will use something else.

                             

                           

                             

                          Regards,

                             

                           

                             

                          James

                          • 10. Re: CY8CKIT-042 PSoC 'ES' ?
                            user_14586677

                            I am at a remote site, so do not have capability of wiring up LCD, but

                               

                            using Pioneer kit I observe the following -

                               

                             

                               

                            1) Delays do not seem to work right

                               

                            2) You do not need LCD_Init(), thats taken care of by Start(), it calls Init().

                               

                            3) Setting breakpoints do not seem to work right, in fact I got a debug error from the tool,

                               

                            not the code, and debug exited on its own.

                               

                            4) I had to update firmware on my board, to 2.03, not sure if this is connected to anything.

                               

                            5) I looked at LCD signaling, looks like display is gettting written to. Again, I do

                               

                            not have a display connected.

                               

                             

                               

                            I would post a CASE at (point them to this thread) -

                               

                             

                               

                            "www.cypress.com"
                            "Support"
                            "Technical Support"
                            "Create a Case"
                             

                               

                             

                               

                            Regards, Dana.

                            • 11. Re: CY8CKIT-042 PSoC 'ES' ?
                              user_1377889

                              I found some remarks regarding the ST7066U needs some longer delays than the Hitachi controller requires. There are some complains of other users not getting the chip initialized or needing two initialization sequences. I would suggest you to check for solutions provided.

                                 

                               

                                 

                              Bob

                              • 12. Re: CY8CKIT-042 PSoC 'ES' ?
                                user_1377889

                                @Dana

                                   

                                Can you provide me with an example of your non-working debug environment? I'd like to verify that.

                                   

                                Bob

                                • 13. Re: CY8CKIT-042 PSoC 'ES' ?
                                  user_14586677

                                  I made a little progress, but breakpoints still not working.

                                     

                                  In fact board breaking at API C code, but all BPs have been cleared ?

                                     

                                   

                                     

                                  I also changed to Minprog3 to see if PSOC 5LP causing issues. No

                                     

                                  luck.

                                     

                                   

                                     

                                  Regards, Dana.

                                  • 14. Re: CY8CKIT-042 PSoC 'ES' ?
                                    user_1377889

                                    @Dana,

                                       

                                    "In fact board breaking at API C code" I had a similar experience once, after removing the USB-Port driver and rebooting PC and re-connecting the Pioneer-board that bug was gone. All happened on a vista machine.

                                       

                                     

                                       

                                    Bob

                                    1 2 3 Previous Next