4 Replies Latest reply on Apr 28, 2016 10:39 AM by ron.sommers_1614546

    CY5677 unrecognized cysmart before and after firmware update.

    ron.sommers_1614546

      I purchased a CY5677 4.2 usb dongle at Digi-Key since none were in stock at cypress at the time. It came in, I plugged it in after installing all relevant kit software for both the 143 and 143-A kits and cysmart 1.2 and it wanted to do a firmware so I updated both the 5lp code and the PRoC code. the kitprog firmware was 2.16 and I used the cysmart 1.2 proc dongle code for the 4.2 CY5677 (BLE_4_2_Dongle_CySmart_256K.hex) it shows up in the device manager as both the UART and I2C but cysmart cannot see it. The 4.1 dongle and module update went fine and the examples work fine. I cannot come up with any kitprog or firmware combination that works. Does anyone have an idea how to get the CY5677 dongle to work in cysmart 1.2.

         

      I tried the following firmware

         

      43 dongle

         

      43-A dongle

         

      1.2.122 version on cypress site.

         

      Any clues. Tried windows 7 pro and windows 10 pro.