1 2 3 Previous Next 39 Replies Latest reply on Jan 1, 2017 1:00 AM by fa235_1780096

    CySmart dongle problem after firmware upgrade

    milivoje.bulajic

      CySmart tool cant detect USB Dongle after firmware upgrade (Utilities tab of PSoC Programmer).

         

      How I can solve this problem?

        • 1. Re: CySmart dongle problem after firmware upgrade
          milivoje.bulajic

          Found solution.

             

          Factory image (KitProg.cyacd) need to be programmed using Bootloader Host

          • 2. Re: CySmart dongle problem after firmware upgrade
            gul

             another solution -

               

             

               

            download the .hex file from this website and program it onto the dongle using PSoC Programmer

               

             

               

            http://www.cypress.com/?rid=102636

            • 3. Re: CySmart dongle problem after firmware upgrade
              user_389839849

              Hello,

                 

               

                 

              Just received the new psoc4 BLE kit and also have problems with the BLE dongle.

                 

              At first CYSMART told me that BLE dongle firmware is out of date and i have to upgrade it!!!

                 

              Upgraded with the .hex files in the kit dvd , no success..then tried to use the .hex file from the cypress site..also no success?

                 

              Programming seems to be fine., but CYSMART does not recognize at all??

                 

              What to do now??

                 

               

                 

              thanks in advance

                 

               

                 

              Amarant

                 

              PS attached screenshot of programmer(after done the programming)

              • 4. Re: CySmart dongle problem after firmware upgrade
                content.librarian

                Things to try out:

                   

                1. After connecting the dongle to the USB port, reset the dongle by pressing the switch SW1

                   

                2. Try clicking refresh button on the CySmart dongle selection window multiple times

                   

                3. As suggested in the post above, try programming the PSoC 5LP device on the BLE dongle with KitProg.cyacd file using the bootloader host utility (PSoC Creator -> Tools -> Bootloader Host). The kit guide should have info on how to program the .cyacd file.

                • 5. Re: CySmart dongle problem after firmware upgrade
                  user_389839849

                  Thanks.. I tried 1.2.3 without success..

                     

                  with the PSOC programmer i can reach the PSOC4  BLE on the USB stick...

                     

                  Compiled the BLE_Dongle_CySmart.cywrk (from DVD) ,seems to compile ok... then programmed it into the USB dongle, also seems to work ok.

                     

                  But still not working??

                     

                  HELP HELP

                     

                   

                     

                  Ron

                  • 6. Re: CySmart dongle problem after firmware upgrade
                    milivoje.bulajic

                    Upgrade firmware on PSoC programmer Utilities tab, updates firmware on programmer IC.

                       

                    If you done that, you need to revert programmer on dongle to factory firmware (KitProg.cyacd) and after that update firmware on BLE IC (.hex file).

                    • 7. Re: CySmart dongle problem after firmware upgrade
                      user_389839849

                      Thanks..

                         

                      I have upgraded firmware on utility tab programmer, seems ok.

                         

                      But i do not understand " If you done that, you need to revert programmer on dongle to factory firmware (KitProg.cyacd)"

                         

                      If i programm the KitProg.cyacd file then i get an error message back, "invalid file format" or so.

                         

                      can you pls explain how to do that?

                         

                       

                         

                      thanks in advance

                         

                       

                         

                      Ron

                      • 8. Re: CySmart dongle problem after firmware upgrade
                        milivoje.bulajic

                        On dongle board are 2 IC. One is programmer and other is BLE SoC.

                           

                        For CySmart dongle funcionality you need to upgrade firmware on BLE SoC (not firmware of programmer itself!)

                           

                        In utility tab you can upgrade firmware for programmer IC. If you made that mistake (you did it) and upgraded firmware of programmer you need to revert it to programmers factory firmware (KitProg.cyacd). You can done that using Bootloader Host tool which you can find in PSoC creator. Search trough manuals for procedure.

                           

                        After that, upgrade BLE SoC firmware using PSoC programmer (programmer tab, not utilities!)

                        • 9. Re: CySmart dongle problem after firmware upgrade
                          user_389839849

                          Hi,

                             

                          Have been experimenting a bit with the psoc4 ble kit and sofar:

                             

                          1-can program pioneer kit with psoc4 ble module..works...also BT coonection to IOS apps and to BT on my PC.

                             

                          2-reprogrammed USB dongle with example project...(alert light,being slave device) and pioneerkit as master(central) BLE

                             

                          This all seems to work?? so i can reprogram USB dongle!!

                             

                          But still cysmart does not recognise my USB dongle???

                             

                           

                             

                          Ron

                          • 10. Re: CySmart dongle problem after firmware upgrade
                            user_389839849

                            hi, thanks again..

                               

                             

                               

                            Did all you wrote..

                               

                            programmed bootl;oader and programmed .hex into psoc4ble.

                               

                            still cysmart not working..???

                               

                            if i use slider example on pioneer kit ble then it works.it connects to dongle and i can slide and at USBdongle the blueled is changing..

                               

                             

                               

                            What to do now??

                               

                             

                               

                            i noticed in the windows device control that the name of the serial port of the USB dongle=> "kitprpg usb-uart(com4).

                               

                            i get the same name, except at com 14, when i plug in the pioneerkit ble

                               

                            is cysmart looking for a particular usb serial name?

                               

                             

                               

                            Ron

                            • 11. Re: CySmart dongle problem after firmware upgrade
                              milivoje.bulajic

                              Section 3.8 of Bluetooth ® Low Energy (BLE)Pioneer Kit Guide:

                                 

                               

                                 

                              The BLE Pioneer kit and Dongle contains the modified KitProg that is required to reliably use the
                              BLE Pioneer kit's functionality. Do not update the KitProg firmware on PSoC 5LP on this kit. If the
                              KitProg has been updated with the firmware provided with PSoC Programmer, then you can restore
                              the original KitProg for this kit using the Bootloader Host tool. The required CYACD file is present in
                              the installed location of the kit:
                              <Install_Directory>\CY8CKIT-042-BLE Kit\<version>\Firmware\Programmer\KitProg
                              \KitProg.cyacd
                              Follow the steps in the Advanced Topics chapter on page 113 to restore the KitProg using the Boot-
                              loader Host tool.

                                 

                               

                                 

                              Read section 6.4.1.2 for solution details if you done something wrongly.

                                 

                               

                                 

                              That worked for me.

                              • 12. Re: CySmart dongle problem after firmware upgrade
                                user_389839849

                                hi,

                                   

                                 

                                   

                                Still not working...

                                   

                                Have the feeling that the USB dongle has the wrong USB driver installed (the same as the psoc4 pioneer kit,"kitprog usb-uart")

                                   

                                Maybe cysmart does not recognize the USB dongle therefore???

                                   

                                Where can i find the correct USBdongle USB driver(.inf)??

                                   

                                Thanks in advance

                                   

                                 

                                   

                                Bye Ron

                                • 13. Re: CySmart dongle problem after firmware upgrade
                                  user_285756223

                                  I see  the KitProg.cyacd.. 

                                     

                                  I have inadvertently quick triggered the programmer and have 'upgraded' the firmware by accident to what it now shows asKitProg version 2.08

                                     

                                  I have tried usingn the Bootloader Host to download the KitProg.cyacd from the downloaded kit on the webpage..  however the Bootloader gives me an error --

                                     

                                  09:59:21 AM - Programming Started
                                  09:59:22 AM - Communication port reported error 'Unable to write data to the target device'.
                                  Programming completed in 412ms.
                                  10:02:45 AM - Selected device: KitProg/1808172A011A3400

                                     

                                  And as previously reported by others, CySmart ignores the dongle now entriely..

                                     

                                  What am I missing here to get the bootloader to get me back to square one, so to speak :)

                                     

                                  --thx
                                   

                                  • 14. Re: CySmart dongle problem after firmware upgrade
                                    user_285756223

                                    Hi all...

                                       

                                    The fix we all need to reset the dongle after we have prematurely hit the trigger in the programmer and upgraded the device to the wrong bootloader .. is in the kit guide on pg 146, section 6.4.1.2 Restore PSoC 5LP Factory Program Using USB Host Tool

                                       

                                    There is also a procedure using the programmer, but it doesn't allow (as far as I could find) a way to load the specific bootloader KitProg.cyacd that we need here.. so it fails to do the job...

                                       

                                    Using the Bootloader Host tool is the way to get it done...  just follow the directions, holding down the SW1 reset button as you insert the device into the USB port (a cable may make this easier)... then the download will work as desired..

                                       

                                    Afterwards, then use the programmer to download the BLE_Dongle_CySmart.hex file from the kit in Cypress\CY8CKIT-042-BLE Kit\1.0\Firmware\BLE Dongle\Hex Files

                                       

                                    reset the device and then launch the CySmart program and all should be well with your world once again...

                                       

                                    Hope this helps get us all back running again :)

                                    1 2 3 Previous Next