7 Replies Latest reply on Nov 2, 2015 12:58 PM by mblnkml_1512656

    Bootloader Host not seeing board

    user_301847813

       Today I updated from Creator 3.0 SP2 to 3.1, and since then I haven't been able to get a board using a Cypress USB-UART bridge to show up in Bootloader Host. It shows up in Device Manager, but not in Bootloader Host.

         

       

         

      I have unstalled everything Cypress and reinstalled 3.1, but still no luck. Any ideas before I uninstall 3.1 and reinstall 3.0?

        • 1. Re: Bootloader Host not seeing board
          user_1377889

          You probably do not need to re-install 3.0, it should still be in your program-folder.

             

          Sure that no filter in Bootloader Host hinders the com-port to show up?

             

           

             

          Bob

          • 2. Re: Bootloader Host not seeing board
            user_1377889

            I just checked with a brand new Prototype Kit on my win7 system:

               

             

               

            Starting Creator 3.1

               

            Inserting Board, drivers get installed

               

            Removing board

               

            Insert Board while pressing the switch. Blue LED blinks

               

            Starting BootLoader Host, on my pc com28 is automatically selected.

               

            Setting baud-rate to 15200

               

            Test programming successfully

               

             

               

            Bob

            • 3. Re: Bootloader Host not seeing board
              user_301847813

               Yup, no filters are active, and I can see other serial ports in the Bootloader Host window, just not this one. I was programming it with no issues before updating, as was a friend.

                 

               

                 

              As part of trying to figure out what was going on I uninstalled everything Cypress, and then did a fresh install of 3.1. I still can't see the board in Bootloader Host. Before I did that I tried to use the 3.0 Bootloader Host, and it no longer worked either.

              • 4. Re: Bootloader Host not seeing board
                user_14586677

                Not sure if this impacts your design, from 3.1 release notes -

                   

                 

                   

                Default Stack and Heap Sizes
                The default stack and heap sizes for new projects have been adjusted to more closely match real-world
                requirements. When new projects are created, the stack size is set to be a fraction of the total SRAM in
                the target device. The heap is set to a small value - 128 bytes - for all devices. You can, of course, modify
                these settings in the Design-Wide Resources System Editor. For example, if you are not using any heap
                based memory allocation the heap can safely be set to 0 bytes.
                Note that some example projects and application notes were originally created on older versions of PSoC
                Creator and use the larger default sizes. These projects will continue to build and run perfectly because
                they have sufficient memory allocated. However, if you attempt to reproduce the example yourself in your
                own project you may need to adjust the stack and heap. However, the example documentation will not tell
                you to do that because the original project did not require the settings to be changed.

                   

                 

                   

                The heap and stack size were reduced in 3.1, try restoring to 3.0 levels 4K and 16K respectively.

                   

                3.1 default settings are now 128 bytes and 2K.

                   

                 

                   

                System tab in Fitterxxxxx*.cydwr file, workspace explorer near the top.

                   



                   

                Ragards, Dana.

                • 5. Re: Bootloader Host not seeing board
                  content.librarian

                   Hi,

                     

                   

                     

                  I'm begginer in PSoC and I'm using a CY8CKIT-049. I had tree times already this issue. I don't know why exactly happens, but one of the reasons is... because to try your design each time you need to UNPLUG the PSoC from the USB, press and hold the button to enter in bootloading mode and PLUG the PSoC back into the USB port. Imagine how many times per day I PLUG and UNPLUG the device!  You can see and manage the PSoC with all the other software provided from Cypress, but ONLY BOOTLOADER HOST can't !

                     

                   

                     

                  SOLUTION to this problem is to go to device manager and DELETE (not just uninstall) the drivers for PSoC, RESTART your PC. Go to location where is your Creator installed, find USB-Serial SDK,  go to DRIVER (not Cypres usb- serial driver) and REINSTALL your drivers. You should see a Command Prompt window during the installation.

                     

                   

                     

                  P.S. CY8CKIT-049 for 4 buck's is a great device, but is not verry user friendly, specially for people like me. Will be verry nice if is possible to be programmed from the creator witout the need of DESTROYING the USB bort.

                  • 6. Re: Bootloader Host not seeing board
                    mblnkml_1512656

                    Is there any other solution to the problem.

                    • 7. Re: Bootloader Host not seeing board
                      user_1377889

                      This thread is more than half a year old, better to start a new one with some detailled description of your issues-

                         

                       

                         

                      Bob