8 Replies Latest reply on Mar 1, 2011 11:26 PM by content.librarian

    Design Challenge Development Kit

    albc_263866

      Is there an option to use the mini prog 3 as debugger in the design challenge development kit?

         

      If not, how do we use the debug feature? 

        • 1. Re: Design Challenge Development Kit
          rachc_288371

          Yes the board has a header for the MiniProg3

          • 2. Re: Design Challenge Development Kit
            userc_39572

            Hi,

               

             

               

            Yes, the 10 pin header provided on the board will allow debugging using Miniprog3.

               

             

               

            Regards,

               

            dasg

            • 3. Re: Design Challenge Development Kit
              albc_263866

               Can the programming chip be used for debugging? Or do we need to get a seperate miniprog 3 for that?

              • 4. Re: Design Challenge Development Kit
                userc_40462

                have you tried using USB for debugging?  Seemed to work for me although I didn't really try setting breakpoints, just single stepped through some code.

                • 5. Re: Design Challenge Development Kit
                  content.librarian

                  You can debug the kit thru either a MiniProg3 (not included) or via USB, using the USB programing connector.  Debug is a little slower via USB, but still supports all of the features.

                     

                   

                     

                  -Bobby

                  • 6. Re: Design Challenge Development Kit
                    content.librarian

                    So, I'm taking it from "rdaley"'s response that at least one person has been able to install the software from the CD (+net).  Am I the only one having trouble?  I've tried to multiple times both before and after "the standard WIndows remedy" (a reboot), and tried both "Typical" and "Complete" package options, and have had no success.  I don't believe that I'm running out of disk space, and happen to be running XP, and am installing (but don't plan on running) as admin.

                       

                    It dies at the same point every time, namely during the download/installation of  "PSoC 5 Development Kit 1.0 Rev**", and I get "Installer is unable to download installation Packages.  Please check your internet connection and try again.  Details: Data error (cyclic redundancy check)."

                       

                    Anyone else had successes or failures?

                       

                    ++tkx

                    • 7. Re: Design Challenge Development Kit
                      userc_40462

                      I've installed it on Vista and XP without any problems. Sorry, I know that doesn't help.  It sounds like the installer got messed up.  I had a similar problem installing the sense and control dashboard.  You may want to install on another machine and copy the data over.

                      • 8. Re: Design Challenge Development Kit
                        content.librarian

                        I was able to get the software for our kits to install only after installing the software for the -001 kit.  After installing the latter, I was able to install the former -- which took almost no time because it appears that well over 90% of the software is common, and so virtually nothing else had to be installed to get the -050 software going.

                           

                        From all symptoms, it appeared to be a bad software module in the download area for the -050, but was good in the -001 package.  I suppose it's possible that a locally cached -050 package was corrupted and wasn't getting displaced by a good one from the server by the downloader, in spite of 3-4 attempted uninstalls and re-installs.

                           

                        Unfortunately I don't have second machine at my disposal to compare its behavior against, but hopefully what I've got installed now is complete and correct.

                           

                        tkx