9 Replies Latest reply on Oct 9, 2014 11:11 PM by userc_9295

    Wiced Sense factory recovery

      Hi,

       

      I'm desperately trying to recover my Wiced Sense device with the factory image using "Wiced Sense SDK 2.1 v1.1 Firmware "

      .

      I followed every steps from the blog, including recovery process.

       

      Building and downloading process is fine.

       

      The problem I'm facing is that device is only discoverable for a few millis when I insert the battery, led1 stops changing its brightness and device seems to go offline.

      No connection can be then established from central devices and device is not discoverable anymore.

       

      My understanding of the code is when  advertising (normally) stops, "button 2" should restart advertising. That seems not to be the case.

       

      I investigate further on this strange behavior. I built an entire new application, trying to make led2 toggle on every fine timer callback calls. It blinks, but only for the period observed previously.

       

      Am I missing some concepts, like timeouts, deeps sleep or other ?

      Could it be an hardware failure ?

      Anyone facing the same issue ?

       

      I'm using WICED-Smart-SDK-2.1.1-IDE-Installer on Windows 7 / iOS 7 and Android 4.4 for central device.

       

      Thanks for your replies.

       

      Alexis

        • 1. Re: Wiced Sense factory recovery

          Hello Alexis,

           

          We are looking at these issues and will provide an update shortly.

          JT

          • 2. Re: Wiced Sense factory recovery

            Hello Alexisgilabert,

             

            Please check our update from today:

            WICED Sense SDK 2.1 Firmware.zip

             

             

            Let me know how it works for you.

             

            Thanks

             

            JT

            • 3. Re: Wiced Sense factory recovery

              I'm facing same problem with WICED Sense firmware 1.2 (new version).

              Moreover, I'm facing this problem not only wiced_sense app but also sample apps of WICED Smart SDK 2.1.1.

              (hello_sensor, speed_test, proximity, etc.)


              • 4. Re: Wiced Sense factory recovery

                Hello JT,

                 

                Like userc_10203 already said, v1.2 did not solve the problems.

                Brownie is also right about other apps from SDK.

                 

                I'll have a look at the firmware you provided: Wiced_Sense-Image_V1_2.cgs and try other ways to solve this problem.

                 

                Alex

                • 5. Re: Wiced Sense factory recovery

                  Hello JT,

                   

                  I followed instructions from Programming the TAG2/TAG3 Board using command line tools Section 6 to convert cgs file to hex and use ChipLoader to load the file to the Wiced Sense device.

                   

                  So, basically, I copied the following files from SDK/Tools and SDK/Platform/BCM920737TAG_Q32 into a folder:

                  • cgs.exe
                  • ChipLoader.exe
                  • Wiced_Sense-Image_V1_2.cgs
                  • 20737_EEPROM.btp
                  • BCM20737A1.cgs
                  • ConfigDef20732_ab.hdf
                  • uart_DISABLE_EEPROM_WP_PIN1.hex

                   

                  and launched following command lines (with appropriate values) :

                   

                  • cgs.exe -I output.hex -A 0xFF000000 -B 20737_EEPROM.btp -D . Wiced_Sense-Image_V1_2.cgs
                  • Chipload.exe –BLUETOOLMODE –PORT COM1X –BAUDRATE 115200nfc –MINIDRIVER uart_DISABLE_EEPROM_WP_PIN1.hex -CONFIG output.hex -BTP 20737_EEPROM.btp -NODLMINIDRIVER

                   

                  Unfortunately, I got the following error:

                  Download minidriver successfully had written 64 bytes to address 0x00201000

                  Download minidriver successfully had written 64 bytes to address 0x00201040

                  Download minidriver successfully had written 64 bytes to address 0x00201080

                  Downloaded 0 code bytes ( 0.0%) and 0 data bytes ( 0.0%). Verified 0 code bytes ( 0.0%) and 0 data bytes ( 0.0%).  Current state: Terminated with error

                  Download minidriver error trying to write 64 bytes to address 0x002010C0

                   

                  Any clue on what's happening ?

                   

                  Another point: looking at the difference between the cgs file I generated and the one you provided showed me that my "entries" are made of "compressed data" and yours are only "data".

                  e.g ENTRY "Compressed data" = ".text from ../../build/wiced_sense-BCM920737TAG_Q32-rom-ram-Wiced-release/A_20737A1-wiced_sense-rom-ram-spar.elf" vs ENTRY "Data" = ".text from ../../build/wiced_sense-BCM920737TAG_Q32-rom-ram-Wiced-release/A_20737A1-wiced_sense-rom-ram-spar.elf"

                  I think this is quite normal as the files in the build folder are .ccgs (i guess it means compressed cgs), but could this be the reason we can't get functional firmware ?

                  I read in BCM20732 Memory Map Architecture that SFLASH uses uncompressed images. So, should I load your firmware into SFLASH instead of EEPROM ?

                   

                  Thanks

                  Alex

                   

                  jota_1939431 userc_10203

                  • 6. Re: Wiced Sense factory recovery

                    Hello Alex and Brownie,

                     

                    Thanks for your patience on this issue.

                    The compressed data and data is the reason why you can't program with the cgs file

                     

                    However, I have a work-around for fixing the original issue and I will post the changes today.

                     

                    We have a crystal warm-up issue and I will post the video on the BLOG site for you to see.

                     

                    Crystal Warm-Up Workaround

                     

                    Please change the Crystal Warm-up time from the 2800 value to 5000 in the mandatory.cgs file located at: C:\Users\jtate\Documents\WICED\WICED-Smart-SDK-2.1.1\WICED-Smart-SDK\Wiced-Smart\tier2\brcm\mandatory\bld\20737\mandatory.cgs

                     

                     

                    ENTRY "PMU Crystal Warm up Time"

                     

                    {

                     

                      "Crystal warm up time" = 5000

                     

                    }

                     

                    Short video showing the change is on the BLOG:

                    WICED SENSE Kit BLOG

                     

                    Thanks.

                    JT

                    • 7. Re: Wiced Sense factory recovery

                      Hello brownie,

                       

                      Try the Crystal Warm-Up Workaround on the BLOG.

                       

                      We tested and it works.

                       

                      Thanks

                      JT

                      1 of 1 people found this helpful
                      • 8. Re: Wiced Sense factory recovery

                        Thanks JT,

                        It worked fine!

                        And other samples of WICED Smart SDK are worked fine too


                        • 9. Re: Wiced Sense factory recovery

                          Thanks JT,

                          It works now perfectly.

                          Alex