3 Replies Latest reply on Apr 9, 2010 3:23 PM by anandsrinivasana_

    Beginner's problem

      I am trying to get my fx2lp working (68014a). I have designed and manufactured a simple sample board.   
      If I plug it in, it enumerates as fx2lp, eeprom missing. (There is an empty eeprom) So far, so good.   
      Next I tried to load some demo apps found in (cy3684_ez_usb_fx2lp_development_kit_15.exe).   
      None of them worked (tried bulkloop, and some others). Not so good. The Windows error message is something like: The device cannot be recognised. VID/PID is 0000/0000. I assume 0000 is the default value for unrecognizable devices. Not even asking for drivers.   
      Then I installed the .NET tools (suiteusb_net_2_0___usb_development_tools_for_visual_studio_2005_and__net_2_0_3_0_14.msi). I downloaded the CYStream hex. Windows recognised it well (correct VID/PID). But after browsing the driver I got an error no. 10: The device cannot be started. Not good.   
      The next sample I tried was: application_note_source_code___bus_powered_enumeration_with_fx2_13.zip. After downloading the hex file, it worked. It is a Bulkloop example, again! I even managed to create a modified .inf driver file. It works well with the Cypress USB console. But the Suite.NET component does not recognize the device as an USB device (USBDeviceList does not find it) although it finds my external HDDs and my keyboard also.   
      I also found an other example: cystream___streaming_over_usb_with_isochronous_and_bulk_transfers_19.zip. CyStream again. I downloaded the iic file successfully to the EEPROM, Windows enumerated the device as CY-Stream, but the driver failed again: error 10, the device cannot start.   
      I am kinda stucked here. All I want is a working sample, bulkloop would be great, and a working .NET interface for start.   
      Can anyone help?   
      What did I wrong?   
        • 1. Re: Beginner's problem
                  Hi demodl,   
          There is pcb layout recommendations and schematics available. take a look into them. This 0000 Vid/pid is mostly a problem due to the schematics. The .net interface not recognising your device is due to the absence of driverguid value in the registry. In the inf file uncomment the cyus.guid and Driverguid.addreg section. this should resolve the .net interface problem.   
          • 2. Re: Beginner's problem
                    I get the same problem, but with a FX2 Ev Board from Cypress. If I convert the programm.hex file (my little program, working well if programmed by EZ-USB Control Panel / Download...) by commando {hex2bix -F 0xC2 - I programm.iic programm.hex} to a .iic file and download it by EZ-USB Control Panel / EEPROM I get the same error after resetting the device.   
            What do I wrong?   
            Thanks! Regards, Jan   
            • 3. Re: Beginner's problem
                      even if a few bytes of your firmware lies in external memory then you'll have to use -e option instead of -i option... or is your firmware fully in internal memory????