3 Replies Latest reply on Apr 9, 2010 3:26 PM by anand.srinivasan.asokan

    Problem with ezloader driver

    dmitry.m.
              Hello! I have a problem with ezloader driver when trying to upload firmware code of a definite size to the device (EZ-USB FX2 / FX2LP).   
      I have created project with my firmware code and compiled it in Keil uVision. The output is .HEX file. It heve uploaded it with Control Panel successfully. The device worked.   
      Using "EZLoader Custom USB Firmware Loader Drive" note I have created my own driver that was uploading my firmware automatically to the device. The device worked successfully.   
      All was ok until the size of the project became >11K (about). The .HEX file is still may be uploaded with Control Panel and device works. But when I make my ezloader driver with firmware code >11K, the driver works uncorrectly. When I attach the device it goes the endless cycle of uploading firmware without any errors.   
      The problem is size of firmware code when uploading it with driver.   
      I have seen such a problem but haven't seen the solution.   
         
        • 1. Re: Problem with ezloader driver
          anand.srinivasan.asokan
                  what do you mean when you say endless cycle of uploading firmware without any errors. Did you use some kind of bus analyzer????   
          • 2. Re: Problem with ezloader driver
            dmitry.m.
                    Maybe I explained my problem incorrectly...   
            I have created driver (for example Antloader.sys) which has similar functionality as ezloader.sys (uploading of .HEX data). It was created with help of hex2c.exe and Windows DDK (version 2600.1106). Also I have created appropriate INF file that attaches driver Antloader.sys to the device by its VID/PID.   
            After the connection of the device to PC (where the device with such a VID/PID have never been connected) I selected Antloader.sys with the help of Device Manager. Device Manager began copying but couldn't finish it (endless copying).   
            I have disconnected the device and connected it again. (I have checked - Antloader.sys had really been copied to ..\system32\drivers\).   
            The device looked like successfully installed in the list of Device manager with Antloader.sys (but in the properties of the devices driver Antloader.sys was unloaded). If the ReNumeration is completed correctly the device should appear with other VID/PID and ask for the new driver. But there were no messages about errors or conflicts.   
            And then:   
            - all the connection are followed by appearance of the device in manager with unloaded driver Antloader.sys;   
            -after deleting Antloaderer.sys and connection the device appears with exclamation mark and without any driver (in the properties);   
            -the same situation repeats on other PCs;   
            -after replacing Antloader.sys with standard Ezloader.sys (renamed to Antloader.sys) the renumeration completes successfully and the device appears with new VID/PID correctly.   
               
            When I create the same Antloader.sys with .HEX data less than 11K all the operation with driver complete correctly.   
            Why may firmware uploading driver work incorrectly? Are there any limits for the .HEX data file (in this way of firmware upload; when I use Control Panel with .HEX data >11K operations complete successfully).   
            • 3. Re: Problem with ezloader driver
              anand.srinivasan.asokan
                      I've not come across this kind of situation. If it replicatable in other PCs then there must be something funny going on... can you upload here the .hex, the working antloader and not working antloader???   
              observing the CATC would give a better view of what is actually going on i.e atleast if the loading is kicking in....   
              one more thing, which version of the driver are you using (did u try using the cyusb.sys that comes with suiteusb 3.4.1)???