5 Replies Latest reply on Apr 9, 2010 4:28 PM by anand.srinivasan.asokan

    Problem while installing CYStream application

    neelima.t
              Hi,   
         
      I am using EZ USB FX2LP development kit. I tried to install CYStream firmware into the CY7C68013A controller following the steps given in CYStream Users guide. The device got enumerated as CYStream DevKit Device but the error is shown as the device cannot start (code 10). Please anyone help me in resolving this.   
         
      I tried to erase the EEPROM for changing the firmware but i couldnt get the EEPROM eraser. Please let me know where can I find the USB EEPROM eraser or how to upgrade with different firware.   
         
      Regards,   
      Thota.   
        • 1. Re: Problem while installing CYStream application
          anand.srinivasan.asokan
                  I see one thing that might have gone wrong.... The memory configuration of the firmware might be using external memory and you might have the board jumpers set such that it does not use external memory.   
          Regarding the EEPROM eraser, there is nothing like that... in the DVK you will have switches to disable the EEPROM... you can just switch them off while plugging in the board... later you can switch it on and reprogram it with a EEPROM image of your desire...   
          Try rebuilding the cystream firmware with different memory configuration and loading it to EEPROM...   
          • 2. Re: Problem while installing CYStream application
            neelima.t
                    Thanks for your quick reply. The board doesnt have any switches or jumpers to disable EEPROM. So please let me know if there is any alternative solution for this.   
               
            CyConsole EZ-USB application is not able to recognise the device and so iam not able to load the firmware again. Please let me know if there is any other application from which i can download the firmware but the device is getting enumerated when i connect to PC with the same error "the device cannot start".   
            • 3. Re: Problem while installing CYStream application
              anand.srinivasan.asokan
                      You said you are using FX2LP development kit. The development kit has switches... Are you using a custom board? because without disconnecting the EEPROM i don't think you'll be able to work around this problem...   
              • 4. Re: Problem while installing CYStream application
                neelima.t
                        Sorry i got confused. I rechecked the product information. It is given as it can be used EZ-USB FX2 development kit software. The kit is purchased from Elrasoft. But when i checked with FXL2P development software, it worked previously. So i thought its FXL2P development kit. Now if i have to disconnect EEPROM, can you tell me if there is any procedure. This board doesnot have switches.   
                • 5. Re: Problem while installing CYStream application
                  anand.srinivasan.asokan
                          Check if the EEPROM is connected to supply through a pull down resistor.... if so grounding the supply pin of the EEPROM should stop the boot-loading from EEPROM part... after this you should be able to bind it to the driver and reprogram the EEPROM...