7 Replies Latest reply on Dec 26, 2010 9:44 AM by gautam.das.g

    Creator Beta 5 Killed My Project

    dan.siewers

       I updated to new software release and now the project I've been working on for over a month does not work!

         

      I tried building after updating components and when that didn't work re-copied all files from archive and tried building it without updating components.

         

      When I updated the components even the UART didn't work reliably.

         

      Any help would be greatly appreciated.

         

       

         

      Dan

        • 1. Re: Creator Beta 5 Killed My Project
          dan.siewers

          As a follow up..

             

          I'm starting to breathe life back into this thing.
          When initialially loading up the project I had to make sure to tell Creator to not flag the project for component updates.
          Then I had to systematically delete each component and drag in and configure the newer version component in its place.
          Some of the bus lines had to be redrawn as well.

          However, I'm having trouble with isr components so I'll tackle those next.

             


           

          • 2. Re: Creator Beta 5 Killed My Project
            user_611219

            Have a look at the Component Changes section of the new ISR component datasheet. It will give you insight into what has changed, and possibly why the new component is not working as expected. As an example, it now has an Interrupt Type parameter.

            • 3. Re: Creator Beta 5 Killed My Project
              dan.siewers

              At the moment I'm having a major issue with the 1.50 version of the UART component.
              The 1.20 version work great for me and I have it configured as TX only.
              When I swap it out for 1.50 it behaves in a strange manner.

              • 4. Re: Creator Beta 5 Killed My Project
                dan.siewers

                Sorry about multiple posts.
                The last post has a picture attached that shows what the UART v1.20 spits out.
                This post shows what UART v1.50 spits out. Same project with no changes other than the UART.
                I've read through datasheet a few times and both versions of the UART seem to be configured the same.

                   

                Does anyone know what's going on?

                   

                Dan

                • 5. Re: Creator Beta 5 Killed My Project
                  dan.siewers

                   Also, I got the interrupts working properly.

                     

                  I had to delete the originally generated sources and rebuild the project.

                   

                  • 6. Re: Creator Beta 5 Killed My Project
                    dan.siewers

                     I got the UART to work.The only way I could make it work was to place a 1ms delay for small loops:

                       

                     

                       

                    I tried increasing the TX buffer size but it has no effect.
                    The older version UART didn't behave this way.

                       

                    So for a UART configured TX only at 57600,8,N,1 no flow control:

                       

                     

                       

                    for (i=0; i<14; i++)
                     {
                      CyDelay(1);
                      UART_WriteTxData(RAM_Read((uint16)i));
                    }

                       

                     

                       

                    It won't work properly without the delay.

                    • 7. Re: Creator Beta 5 Killed My Project
                      gautam.das.g

                      Hi kokovec,

                         

                       

                         

                      Instead of using UART_WriteTxData( ) API, you can as well try using the API UART_PutChar( ) which is a blocking one. It doesn't transmit until the previous transmission is done thereby eliminating the requirement of using a delay.

                         

                      On the other hand, while using UART_WriteTxData( ), the buffer status must be checked. Using sufficient amount of delay will also help (which you have followed in your case). 

                         

                      Please let us know if it helped.

                         

                       

                         

                      Regards,

                         

                      dasg