5 Replies Latest reply on Feb 10, 2011 1:29 AM by robert.seczkowski

    Miniprog3 revA suddenly failed

    robert.seczkowski

      I have one chip connected with address 04. I can't communicate with it via I2C although I am able to program it.

         

      During I2C session response alwas is FF-

         

      I conclude miniprog3 failed, because I't worked with several chips in the morning, but now it don't wiht neither of them.

         

      ALso there is a strange device listing. Can someone try listing devices connected.

         

      Miniprog3 device listing (using List button:

         

      Devices list:  8bit  7bit
           address:  0C    06
           address:  0E    07
           address:  1A    0D
           address:  26    13
           address:  32    19
           address:  3E    1F
           address:  4A    25
           address:  56    2B
           address:  62    31
           address:  64    32
           address:  70    38
           address:  7C    3E
           address:  7E    3F
           address:  8A    45
           address:  96    4B
           address:  A2    51
           address:  AE    57
           address:  BA    5D
           address:  BC    5E
           address:  CA    65
           address:  D6    6B
           address:  E2    71
           address:  EE    77
           address:  FA    7D
       

        • 1. Re: Miniprog3 revA suddenly failed
          robert.seczkowski

          I found there is a 5.01V on SCL line where chip supply is 4.9V

             

          I definitely comes from MiniProg. I2C standard doesn't mention about puting power to SCL

             

          Regards

             

          Robert

          • 2. Re: Miniprog3 revA suddenly failed
            robert.seczkowski

            Does anyone know what means Voltage: 2760mV in Bridge Control Panel status bar?

               

            I found, that when Vtarg (chip supply) is disconnected from the chip with SCL and SDA

               

            connected the voltage shows 4180mV (although the output voltage is 5010mV). At the same time SCL

               

            line supplies with 5010mV. It's like SCL line power supply.

               

            But when Vtarg connected, voltage displayed drops to 2760mV.  although VCC is still 5010mV.

               

            I think the voltage in status window  is the one on sda line. It's app the same when miniprog3 disconnected.

               

            But when connected to the chip all pins voltage is 5V, although the status window shows 2760mV

               

            The strane is that on bare chip ( without anything) I2CBridge works well

            • 3. Re: Miniprog3 revA suddenly failed
              robert.seczkowski

              Secondly when I toggle power off the power pins don't switch off the power.

                 

              I have a circuit, which switch on power when Miniprog switch it on.

                 

              I expected the miniprog to take off power when toggled.

                 

              And it worked well, but suddenly, it doesn't want to take off power any more. I must replug USB socket.

                 

              Does anyone know the link for older then 2.05 firmware?

                 

               

                 

              Regards

                 

              Robert

              • 4. Re: Miniprog3 revA suddenly failed
                robert.seczkowski

                I think that POwer on SCL PIn of MiniProg3  is cause of circuit damage.

                   

                I have already two of such boards which suddenly stopped responding to MINIPRO3 I2C.

                   

                 

                   

                An there is so little info in MiniProg itself. I have the reason to say that Miniprog3 doesn't isolate

                   

                you from USB ground.

                   

                It is possible, that if Ground potential of USB is different of Power Supply then You have problems.

                   

                regards

                   

                robert

                • 5. Re: Miniprog3 revA suddenly failed
                  robert.seczkowski

                  The miniprog3 when toggled power on uncoditionally powers up SCL line (when under I2C Bridge to USB mode)

                     

                  I'm shocked. This I haven't expected.

                     

                  My circuit is switching on the power to the board, based on VTARG power.

                     

                  If regardless of Vtarg power on  the power on the circuit don't appear, the SCL line becomes power supply, whick in my case damage the circuit.

                     

                  Regards

                     

                  Robert