2 Replies Latest reply on May 20, 2011 8:23 AM by makarand.patil.2

    PLC modem Transmitt Enable

    user_11959055

      The circuit I have designed to drive the transmit line makes it difficult to use the transmit enable pin.  Could I use the configuration bit to turn off the Analog output buffer inside the chip instead?  Something like this:

         

      ABF_CR0 &= ~ABUF0EN;

         

      ABF_CR0 |= ABUF0EN;

         

      Where would these statements be placed?  I can't seem to find the code that controls the transmit enable.

        • 1. Re: PLC modem Transmitt Enable
          rahul.parsani

           Jack,

             

          The TX Disable pin is used to drive the external TX Amplifier. When the transmit circuitry has a much lower impedance than the receive circuitry. If the Amplifier is not disabled, the chip will not be able to receive any signal from the powerline.

             

          Even if you switch off the buffer, it will not shut down the TX Amplifier. Also, the code that controls the TX Disable pin is a part of the PLT User Module library and cannot be modified.

             

          Could you create a support case and attach the your schematic to that? It will be much easier to help with these issues if I know your circuit better.

             

          Let me know if you need anything else.

             

          Yours truly,

             

          Rahul Parsani

             

          Applications Engineer - PLC

          • 2. Re: PLC modem Transmitt Enable
            makarand.patil.2

            Hello,

               

             

               

            I am working on PLC CY8CPLC20  28PVXI. I am trying to transmit data using main.c code example given in PLT datasheet.

               

            But transmitter is not working. There is some FSK signal at tx pin of IC, when I checked with oscilloscope. But tx_disable pin is always high. It is disabling ampification stage in power line coupling circuitary. So full transmission is not happening.

               

            Why tx_disable is always high when I checked on oscilloscope?

               

            thanks & regards,

               

            Makarand