1 Reply Latest reply on Jul 12, 2011 3:26 AM by udayan.umapathi

    Psoc 3 USB UART problem

    timothee.cazenave

      Greetings,

         

      I working  with a Psoc 3  CY8C3866AXI-040 from the depevelopment  Kit 001. This Psoc 3 is communicating to a CAN network I set up with Psoc 5 controllers from the CY8CKIT-014 for each CAN bus.

         

      I am currently sending all the messages on the CAN line to the "main" Psoc 3 controller. I would like this controller  to also communicate to my CPU through serial communication to send the information from the CAN line and receive specific instructions form a user (using Labview). The Psoc 3 is also communicating meanwhile through serial communication to a Pololu Maestro 24 microcontroller that control several actuators. 

         

      The CAN network is working fine , however I start having some difficulties when I try to communicate to the computer in the same time. I downloaded the USBUART application from the cypress website, this application works fine when I do not add anything to it. But in order to use the USB port I had to change the clock speed of the psoc 3 controller. Once the speed changed,  I cannot perform any extra operations such as using LCD display or ADC reading. Most importantly, the CAN communication does not seem to work anymore even if I change all the clock speeds of the microncontrollers on the CAN line.

         

      I am an Aerospace control engineer and hardware is not my specialty at all. Is there something I am missing maybe when using USBUART with other applications like CAN and LCD display? 

         

      Also,  in case there is no quick easy fix to this problem, would it be possible to communicate to the board through a RS-232 cable, while the board is still communicating through CAN and serial to the pololu microcontroller? With one of this cables for instance:

         

      http://www.google.com/products/catalog?hl=en&q=USB+RS-232+cable&bav=on.2,or.r_gc.r_pw.&biw=1024&bih=683&um=1&ie=UTF-8&tbm=shop&cid=4887864407186723721&sa=X&ei=JUcbTpjkJoi00AHExpSWBQ&ved=0CHYQ8gIwBQ

         

      I have attached a picture of the current project (which is not working because of the USBUART)

         

      Thank you very much,

         

      Timothee