Any reason why need to change name of libray function?
I don't think it is a good thing to rename library function. If I need to, I will do something like
char myPutChar(char ip)
then call myPutchar() later on.
Could you tell us why you are trying to do this ?
Thanks very much for your reply.
Sure, it can be done by retargeting to a function named differently. What puzzled me is the difference for retartgeting functions in Creator. In KEIL, both functions can be redefined directly.
For your question about my senario: getchar() can't be redefined in creator. So I can't use scanf() directly in Creator now.