8 Replies Latest reply on Apr 23, 2012 10:17 PM by yeo.swee.huei

    Select debug target???

    yeo.swee.huei

      Hi,

         

      I am preesntly using PSoC creator 2, and the chip CY8C5568AXI-060.

         

      When I clicked the program button of the PSoC creator, a message box pop out (as per attached file).

         

      Can anyone please advise how to proceed?

        • 1. Re: Select debug target???
          yeo.swee.huei

          Just to add, originally I thought that maybe the chip is spoiled, and so I changed to a new development kit. However, I still get the message pop-out.

             

          I have also tried changing to another usb port, reboot my laptop, re-install creator 2, but neither works.

          • 2. Re: Select debug target???
            user_1377889

            What exactly happens when you click on one of the buttons in your window?

               

            There have been some issues (so I've) red related to the cable only, could you try out another one?

               

             

               

            Bob

            • 3. Re: Select debug target???
              yeo.swee.huei

              Hi Bob,

                 

              I have tried using another programming cable, but the meassage box (screen capture attached in first post) still appears.

                 

              I have also tried using another laptop to program, but the problem still persists.

                 

              Could it be that my pin assignment to the I/O port be the cause?

                 

              Thanks.

              • 4. Re: Select debug target???
                sridhar.m

                 Hello Swee Huei ,

                   

                what error message do you get when you right click on miniprogID ( DVKProg5/XX..XX) and port aquire ?

                • 5. Re: Select debug target???
                  user_1377889

                  Since "Your pin-assignment" is not yet programmed into your PSoC5 and the programming did not yet start this will not be the cause of the issue.

                     

                  The programmer has to connect at first to your programming-hardware. As you can see in your posted message-window it did find a "DVKProg5" obviously with a revision 1a. Now you should "connect" to this hardware and so we are interested in the ongoings when you right-click on the "Connect"-button.

                     

                   

                     

                  Bob

                  • 6. Re: Select debug target???
                    yeo.swee.huei

                    Hi srim & Bob,

                       

                    Attached is a video and photo of the error message that I encountered, when I right click.

                       

                    It seems that no device is attached, hence I suspect that the chip is spoilt. However this is not the case, as when I used another new development kit, the same error occur.

                       

                    Thanks

                    • 7. Re: Select debug target???
                      user_1377889

                      Thanx for the picture and the video, but the message itself (error in port aquire) would have been quite enough, saving 30MB.

                         

                      Since you changed nearly everything, the remaining cases are few. The port aquire fails when

                         

                      1st. Another program already has access to the port denying the access from your creator.

                         

                      2nd. Mis-matched options for the programming (tools->options). Depending on your DVK. Which DVK are you using?

                         

                      3rd. Programmer version. Within Creator is a programmer-module, did you de-install it separately / control if it becomes de-installed

                         

                       

                         

                      I would suggest, when you cannot go further with our help, to create a technical support case.

                         

                       

                         

                      Bob

                      • 8. Re: Select debug target???
                        yeo.swee.huei

                        Hi Bob,

                           

                        Thanks for your suggestion. I have created a technical support case.