9 Replies Latest reply on Jul 1, 2012 5:03 PM by user_1377889

    Can't make PSOC1 DAC to work

    oleg.shumihin

      Hi,

         

      thanks to the community I've solved many problems but this one made me desperate.

         

      My project is controlling speed of a low power brushed dc motor by controlling openning of a mosfet transistor. I prototyped it with development kit-001 and psoc3 but due to the cost I have to move to psoc1. 

         

      None of my trial to start DAC working succeeded. I have gone through lots of appnotes and datasheets but still no luck. My project has to go to the PCB stage but I have no luck with choosing chip - PSOC3 is expensive but PSOC1 is not working.

         

      Cypress support is no help for me - they tend to reply once per 10 days with most ideas not relative to my project. I get more surveys from them then help.

         

      Lately I followed psoc1 example#3 "ADC to UART with DAC" just to make sure I do everithing right but again DAC not  working. I think, I missed something because compiled example is working. 

         

      Attached project is my trial to follow the examle with the same hardware settings and copied main.c - and still doesn't work. I can't understand that.

         

      Any help is greatly appreciated,

         

      Oleg

         

      and another questions: any ideas what the output impedance of the dac? do I have to buffer it with opamp in order to control gate of a mosfet?