12 Replies Latest reply on Jul 3, 2012 10:59 AM by rama.sai.krishna.vakkantula

    DownloadFw

    richard.cote

      My Visual Studio application uses the function DownloadFw from the CyAPI.lib to download a new img file (USBBulkLoopAuto) into ram of the FX3 evaluation board. However the img seams to be download correctly but the DownloadFw call always return FAILED. Same observation with ControlCenter (Programming Failed).

         

      I use vista on a 32 bits system.

         

      Any idea?

        • 1. Re: DownloadFw
          gleb.levitskiy

          I have the same problem in Win7 64bit and can't solve it, so for a while I work in WinXP. There all work properly.

          • 2. Re: DownloadFw
            dhanraj.rajput

            Please create a Tech support case. Our guys will look into it.

               

            -Dhanraj

            • 3. Re: DownloadFw
              gleb.levitskiy

              What is Tech support case?

              • 4. Re: DownloadFw
                rama.sai.krishna.vakkantula

                Log in here:

                   

                http://secure.cypress.com/myaccount/

                   

                Click on the "MyCases" tab.  There you can see a option create Mycase "Technical Support". Use that to create a technical support case.

                   

                Thanks,

                   

                sai krishna.

                • 5. Re: DownloadFw
                  richard.cote

                   I've opened a case yesterday

                  • 6. Re: DownloadFw
                    joanne.dreitzler

                    I have a similar problem with the Control Center on a PC with the Intel USB 3.0 eXtensible Host Controller.  When I use a PC with the ASMedia XHCI Controller, the Control Center works fine.

                    • 7. Re: DownloadFw
                      dmitri.ruppel

                      I have a similar problem with 

                         

                      Etron USB 3.0 Extensible Host Controller
                       

                         

                      idea: when i use  USB2.0

                         

                      Intel(R) 6 Series/C200 Series Chipset Family USB Enhanced Host Controller - 1C26
                       

                         

                      i can download a new img file, and i can run device  in USB 2.0 only...

                      • 8. Re: DownloadFw
                        dhanraj.rajput

                        We have seen some issue when FX3 is used with Intel USB 3.0 Host. It will be fixed in next release of the SDK.

                           

                        You can get the test build of the FX3 SDK from:

                        ftp://dbfcust:Cust5rvc@ftp.cypress.com/fx3/USB_TEST/FX3_SDK_B789.msiCust5rvc@ftp.cypress.com/fx3/USB_TEST/FX3_SDK_B789.msi

                        Installing the MSI will require uninstall of the previous SDK (and maybe the Eclipse and ARM GCC as well if they used the full installer previously). If this is not acceptable, all of the files in the release can be obtained from the ZIP file below:

                        ftp://dbfcust:Cust5rvc@ftp.cypress.com/fx3/USB_TEST/FX3_SDK_B789.zipCust5rvc@ftp.cypress.com/fx3/USB_TEST/FX3_SDK_B789.zip

                        Both of these links are publicly accessible and can be used directly. Please go through the release notes (change log and known problems sections) before starting to use the new SDK.

                           

                        -dbir

                        • 9. Re: DownloadFw
                          dmitri.ruppel

                          Emmm...

                          Excuse me, but in this archives no lib, drivers or cycontrol center,

                           so it's problem "can't to download a new img file" not solved (((... 

                          • 10. Re: DownloadFw
                            andrew.beveridge

                            Ah yes, I just uninstalled as recommended here.

                               

                            And then installed the update... and was a bit surprised to see that it hasn't put everything back. It's mostly all gone.

                               

                            So now no Eclipse etc.

                               

                            It's not exactly clear what the correct install sequence should be.

                               

                            I'm now going to uninstall the new one, then reinstall the old one, and then see what I can do with the .ZIP instead.

                               

                             

                               

                            I also note that the previous ver 1.1 installed to "c:\Cypress\EZ-USB FX3 SDK\1.1"

                               

                            but the new one installs to "c:\Cypress\FX3 SDK" (different name and no "version" subdirectory.

                               

                             

                               

                            It would be helpful (upgrades would be a little less traumatic) if things could be a bit consistent.

                               

                            Probably not really a good idea to install to "c:\Cypress" either. That's not very Windows.

                               

                            :-/

                            • 11. Re: DownloadFw
                              andrew.beveridge

                              Now it won't install at all.

                                 

                              I tried uninstalling it via control panel - that completed OK.

                                 

                              But then it wouldn't install. It insists there is a version already installed which I should uninstall first.

                                 

                              So I went back to control panel and uninstalled the USB Suite and then tried again.

                                 

                              Still it inisists I should go to control panel an uninstall it. But there are now now cypress things in the list.

                                 

                              So I manually deleted the c:\Cypress directory and tried again.

                                 

                              But still it insists there is a version already installed.

                                 

                              I'm stuck now. There is nothing left to run, nothing left to delete that I can see, But I still can't install the new one.

                                 

                              And now I can't do any FX3 development.

                                 

                              How can I get back to a working setup?

                              • 12. Re: DownloadFw
                                rama.sai.krishna.vakkantula

                                SandyB,

                                   
                                   

                                You might have installed the FX3 SDK full package in your system before.

                                   
                                   

                                Now when you tried to install the FX3_SDK_B789.msi, it might have asked you to uninstall the previous installation.

                                   
                                   

                                Then you might have uninstalled the complete SDK (which includes ARM GCC compiler, Eclipse and FX3 SDK).

                                   
                                   

                                Where as the FX3_SDK_B789.msi install only the SDK files, not the other packages.

                                   
                                   

                                Do one thing, uninstall the FX3 SDK that you recently installed and download the seperate installation files from the same link:

                                   
                                   

                                http://www.cypress.com/?rID=57990. Try installing these:

                                   
                                   

                                     Cypress SuperSpeed USB Suite Installer (32-bit Windows host driver), v1.1.2

                                   
                                   

                                Eclipse MSI

                                   
                                   

                                ARM GCC MSI

                                   
                                   

                                FX3_SDK_B789.msi (you have this with you)

                                   
                                   

                                GPIFII Designer MSI

                                   
                                   

                                Then you can uninstall the FX3 SDK seperatley.

                                   
                                   

                                Also please look at this thread: http://www.cypress.com/?app=forum&id=167&rID=64377

                                   
                                   

                                Regards,

                                   
                                   

                                sai krishna.