9 Replies Latest reply on Aug 4, 2012 3:59 PM by dakn_263916

    PSoC 5 evaluation

    userc_43976

      Hi,

         

       

         

      I have a nerw PSoC5 development kit for evaluation. I updated to PSoc Creator 2.0 and am getting an annoying error that pops up on programming "Error: dbg.M0023: There was an error while programming the device: PSoC Programmer reported error (100 - FAILED! Timeout of SPC polling. Lost communication with chip (Status = 0x02))" It seems to appear at random times and then all of a sudden just disappears again. I have set the clock speed in port configuration to 0.8MHz.

         

      Does anyone have a clue how I can get rid of this permanently?

         

      Thank you!

        • 1. Re: PSoC 5 evaluation
          JoMe_264151

          I would suggest you to file a case; tell them which developement kit.I'm sure, they'll help you out.

             

          Bob 

          • 2. Re: PSoC 5 evaluation
            userc_39993

            the last time I saw and solved this error,was by replacing the MiniUSB cable.Try that.......

               

            Hope this helps :-)

            • 3. Re: PSoC 5 evaluation
              userc_41581

              For very high frequencies like 8Mhz replacing the length of the cable migh actually be an issue. The lower limit on the clock speed is certainly less than 0.8Mhz. Nevertheless, changing the cable is still worth a try. Which PSoC5 eveluation board are you using?

              • 4. Re: PSoC 5 evaluation
                userc_43976

                 Well, I've tried all kinda frequencies. Swapping between JTAG and SWD seems to help but it's still annoying.Using 0.2MHz at the moment and the board I'm using is CY8CKIT-050.

                   

                 

                   

                Thanks for the help!

                • 5. Re: PSoC 5 evaluation
                  thph_292981

                  I had the same problem today. I am using the same KIT (050)

                     

                  I tried another cable and also repaired the Programmer Software (could be done using the Update-Tool and click on Configure).

                     

                  Afterwards it seems to work..

                  • 6. Re: PSoC 5 evaluation
                    userc_41581

                    Reggler, could you try updating the software and replacing the cable, as t.schmid has suggested .

                    • 7. Re: PSoC 5 evaluation
                      WeGa_288606

                      Hello,

                         

                      Was there ever a resolution on this issue? I am now having the same problem with First Touch for PSoC 5. I have tried different cables, repairing the programmer, and reducing the clock speed. I have tried the usual reboot etc... I even tried on a second out of the box kit now to no avail. Any help would be highly appreciated.

                         

                       

                         

                      Cheers,

                         


                      Wess

                      • 8. Re: PSoC 5 evaluation
                        userc_43977

                        i think its not the cable problem... something directly related with the code.

                           

                        if i write "LCD_PrintString("hello world psoc");" no problem .

                           

                        but if i add "LCD_DrawHorizontalBG(1, 0, 16,37);" the error occours...

                           

                         

                           

                         

                           

                        /* ========================================
                         *
                         * Copyright YOUR COMPANY, THE YEAR
                         * All Rights Reserved
                         * UNPUBLISHED, LICENSED SOFTWARE.
                         *
                         * CONFIDENTIAL AND PROPRIETARY INFORMATION
                         * WHICH IS THE PROPERTY OF your company.
                         *
                         * ========================================
                        */
                        #include <device.h>

                        void main()
                        {
                            /* Place your initialization/startup code here (e.g. MyInst_Start()) */

                            /* CyGlobalIntEnable; */ /* Uncomment this line to enable global interrupts. */
                           
                            LCD_Start();
                            LCD_Position(0,0);//no problem
                            LCD_PrintString("hello world psoc");//no problem
                            LCD_DrawHorizontalBG(1, 0, 16,37);//if the line added problem creates
                            for(;;)
                            {
                                //LCD_Char_DrawHorizontalBG(1,1,16,25);
                               
                            }
                        }

                        /* [] END OF FILE */
                         

                        • 9. Re: PSoC 5 evaluation
                          dakn_263916

                          Have you met this condition when using BarGraph calls -

                             

                           

                             

                          LCD_Char_DrawHorizontalBG()

                             

                               Draws a horizontal bar graph.Only available when a bargraph character set has been selected.

                             

                           

                             

                          Regards, Dana.