1 2 3 Previous Next 33 Replies Latest reply on Aug 17, 2012 2:17 PM by gayathri.vasudevan

    CY7C68033 enumeration

    sing.lam

      I am working on a USB drive prototype using cy7C68033 and a NAND flash (Samsung K9KWBG08U1M, 4G byte chip), and found that, upon plug in, the device will be enumerated as "Cypress FX2 - No EEPROM"; however, once I start NX2LP Programmer utility, it will be enumerated as a mass storage device (and drive letter will come out).  Firstly I though it was my firmware error and programmed the default firmware (CY3686FW included in the development kit) but the result was the same.

         

      When the device is enumated as "Cypress FX2 - No EEPROM", it has a VID of 04B4 and PID of 8613, which is different from what I programmed using the NX2LP programmer utility, so probably the chip just failed to read the nand flash - am I correct?

         

      Could someone help me to determine what is keeping the chip from working?  Thanks in advance.

        • 1. Re: CY7C68033 enumeration
          gayathri.vasudevan

           Hello,

             

           

             

          Are you using the NX2LP mounted on FX2LP DVK? Or are you using it in stand-alone mode? When using the first mode, i.e. when no chip is mounted on U1 and the NX2LP-Flex board is mounted on the FX2LP 3684 DVK, bootloader.iic code has to be stored inside the Large EEPROM of the FX2LP board. Please ensure the same.

             

           

             

          Also, while programming using the NX2LP Programming utility, please check and let e know whether the 'Auto Program on device connect' option is checked or not. If checked, please uncheck and try programming.

             

           

             

          Regards,

             

          Gayathri

          • 2. Re: CY7C68033 enumeration
            sing.lam

            I am using standalone version (a newly designed pcb).  Also, the 'auto-program' is checked off.  I wonder if it is the VID/PID problem.

            • 3. Re: CY7C68033 enumeration
              gayathri.vasudevan

               Hello,

                 

               

                 

              Can you please try out the following once again and let me know. 

                 

              1.  Connect the NX2LP with Nand Flash mounted. 

                 

              2. Open the NandMfg utility

                 

              3. Do 'CTL + W' as to erase the Nand Flash.

                 

              4. Download the default firmware into it with Formatting option enabled. (If you have disabled formatting, please do 'CTL + F' as to enable the formatting again. This command will toggle formatting of the media ON and OFF. By default, the utility imposes a FAT32 format on the media at the conclusion of the programming process.) -

                 

               [ * Also ensure "Auto proggram" option is unchecked. 

                 

                 * Try with Enable write protect checked and unchecked.

                 

                 * Check / uncheck 'Nand Page size == 512 Bytes" according to the page size of your nand flash. ]

                 

              5. Once the programmed, please ensure Status bar in Nandfg utility shows " Device programmed and Formatted".

                 

               

                 

              Now try plugging the NX2LP device, with Nand flash mounted, without the utility open. 

                 

               

                 

              If it doesn't still work, please get us one USB trace using any USB traffic analyzer like CATC, with the utility open  when it works, and without the utility open when it fails to enumerate.

                 

               

                 

              Also, I would like to clarify one thing: once the utility is open, and the Mass storage drive appears, are you able to do read and write into the Nand flash, with the utility open, and also after closing the utility?

                 

              Have you tried with different Nand flashes? Is this the case with only one particular nand flash that yiu are trying? Or is the behaviour similar for whichever Nand flash you try?

                 

              Regards,

                 

              Gayathri

              • 4. Re: CY7C68033 enumeration
                sing.lam

                The flash chip is Samsung's K9WBG08U1M (4k page, 64 page per block, 8192 blocks, 2 CE).  I didn't try other chip.

                   

                A new finding is that, after formatting is disabled, it always said "programming failed"

                   

                If util is active, then read/write is ok just as normal usb drive.

                   

                Havn't use USB analyser.  Would try later..

                • 5. Re: CY7C68033 enumeration
                  gayathri.vasudevan

                   Hello,

                     

                   

                     

                  I think you got confused with my long previous response. I wanted you to enable formatting if it was accidently disabled before. Since it is already enabled, it is okay. 

                     

                  So, I understand that with utility open, you are able to read and write normally. Does it continue to do so even after closing the NandMfg utility?

                     

                   

                     

                  Get us the USB trace as soon as you get it.

                     

                   

                     

                  Regards,

                     

                  Gayathri

                  • 6. Re: CY7C68033 enumeration
                    sing.lam

                    If the NANDMFG.EXE is closed, the drive is still there and read/write is ok.

                       

                    I enclosed a capture using Ellisys's USB explorer when the drive is inserted when nandmfg is active.  If the nandmcf is inactive, the transaction stops at the line "SetInterface (0, AltSet=0)

                    • 7. Re: CY7C68033 enumeration
                      gayathri.vasudevan

                       Hello,

                         

                       

                         

                      Please also attach the trace when it is failing to enumerate, i.e., with NandMfg utility close. I would like to see what exactly is happening, like whether the command is being stalled etc. Also, if it is possible for you to attach the trace (Ellisys file as such), instead of screenshot, it would be easy for us to analyze.

                         

                       

                         

                      Regards,

                         

                      Gayathri

                      • 8. Re: CY7C68033 enumeration
                        sing.lam

                        Here they are.  One when no Nandmfg and the other with the Nandmfg running.  Thanks for help.

                        • 9. Re: CY7C68033 enumeration
                          gayathri.vasudevan

                           Hello,

                             

                           

                             

                          I would also like to clarify one more thing. When you are programming Nand flash, what is the status shown in the status bar? Please take a snapshot of the same and attach.

                             

                           

                             

                          Also, when you are opening the Nandfg utility, with the programmed Nand flash mounted, what is the status shown? Is it " Connected to Cypress NX2LP - Unprogrammed USB Device" ? When you are using default firmware, that would be the status. Please confirm the same.

                             

                           

                             

                          What is the status when you are programming with your own firmware (Please  use a different VID/PID other than 0x04B4/0x4617 or 0x04B4/0x8613 or 0x04B4/0x6823 in your firmware). Please let me know the answers for these three questions.

                             

                           

                             

                          Regards,

                             

                          Gayathri

                          • 10. Re: CY7C68033 enumeration
                            gayathri.vasudevan

                             Hello,

                               

                             

                               

                            Also, is it possible for you to attach the Nand datasheet. If possible just give it a try with one different Nand flash.

                               

                             

                               

                            What is the version of the NandMfg utility that you are using? If you are using an older version, please use the latest version that you can find at: http://www.cypress.com/?rID=14320

                               

                             

                               

                            Regards,

                               

                            Gayathri

                            • 11. Re: CY7C68033 enumeration
                              sing.lam

                              When programming, the screen ends with "please use host to format" if formatting is enabled, which I believe is normal because K9WBG08U1M is 4K page which cannot be formatted by NandCfg.  Please see attached screen.  However, if format is disabled (Ctrl-F), then it will said "Programming failed", although if I remove and then re-attach when NandCfg is running, I can access and format the drive.

                                 

                              If unprogrammed device is connected, then "Connected to Cypress NX2LP - Unprogrammed USB Device" is shown.  I can erase the flash (Ctrl-W) and then program.

                                 

                              I tried different VID/PID combinations and there is no difference.

                                 

                              On the NandCfg version, I believe I am using the latest one - please see the version screen capture.

                              • 12. Re: CY7C68033 enumeration
                                gayathri.vasudevan

                                 Hello,

                                   

                                 

                                   

                                Even though from the screenshot you have attached, the version seems to be the same, but I want you to check with the latest version to be double sure. Since we have made certain minor modifications in the NandMfg utilityin the recent past.

                                   

                                Also, I want to let you know that it is the programming to the Nand flash that is failing in your case. I am inspecting further on this. Please let me know after you check with the latest Nandfg utility.

                                   

                                 

                                   

                                Regards,

                                   

                                Gayathri

                                • 13. Re: CY7C68033 enumeration
                                  sing.lam

                                  I have done a re-installation and the result is the same. 

                                     

                                  Another finding: with NandMfg.exe running and the device is recognized, at first the read/write is ok; but after read/write several MB of data, the drive seems gone (Windows cannot detect the drive).  The default4K firmware is used.

                                     

                                  I will try use some other Nand flash chip to test.

                                  • 14. Re: CY7C68033 enumeration
                                    gayathri.vasudevan

                                     Hello,

                                       

                                     

                                       

                                    I think it would be easier and faster to debug the root cause if it is possible for you to ship the Nand flash. as soon as we receive the Nand flash, we will open a tech support case for you, and communicate over that. Please let us know whether it is okay for you to ship the Nand flash. if so, I will tell the shipping address.

                                       

                                    As you test with another Nand flash, please do with other Nand flashes that have 4k page, and also that has 2k/512 page size as well.

                                       

                                    Regards,

                                       

                                    Gayathri

                                    1 2 3 Previous Next