6 Replies Latest reply on Sep 17, 2012 4:58 AM by prajith.cheerakkoda

    Unable to execute a script at start-up

    david.wang

      I am trying to make a INF file which will execute a script at start-up to download the firmware. I am trying it on a 64-bit Windows 7 machine. I obtained the CYUSB.SYS from Cypress Suite USB 3.4.7\Driver\bin\wxp\x64. I used the INF file under Subheading "Execute a script at start-up" in Section "Modifying CyUSB.INF" of "Cypress CyUsb.sys Programmer's Reference" as the template. I have only modified the VID and PID in the INF file. I have also add a string for the second VID_XXXX&PID_XXXX.DeviceDesc (see attached INF file). I also put a script "MyDevice.spt" for firmware download in the same directory of the INF file. The script has been tested successfully using Cyconsole. I am using No EEPROM mode for startup

         

      As the CYUSB.SYS had not been signed, I started the Windows with F8 pressed and then bypassed the Windows driver signature enforcement. Then I plugged the hardware into the USB port, I opened the Windows Device Manager and guided it to the INF file. The driver was installed successfully. But the hardware was only displayed in the first VID&PID in the Windows Device Manager. Therefore, I manually dowloaded the firmware using Cyconsole, then I saw the hardware displayed in the second VID&PID and the firmware worked fine. However, I plugged out hardware and replugged it in, the hardware was displayed in its first VID&PID without the firmware downloaded. I restarted the computer and tried for a few times and still encountered the same problem. It looked like the firmware script was not executed automatically at startup.

         

      What did I do wrong? Any suggestion is highly appreciated!