4 Replies Latest reply on Nov 14, 2012 2:23 AM by user_78878863

    unable to acquire port

    rajendra.prasad

       hi to all,

         

                    when i want to program the CY8CKIT 001 of Psoc 3 kit, it show the error message like unable to acqiure port.

         

      what is the solution for this problem.

         

      thanks

         

      PRP

        • 1. Re: unable to acquire port
          user_14586677

          Some things to check -

             

           

             

          1) Does driver show up in Win Device Manager for Miniprog and no errors shown ?

             

          2) Power on board match project settings ?

             

          3) Silicon ID in project match what programmer trying to acquire ?

             

           

             

          Regards, Dana.

          • 2. Re: unable to acquire port
            kishore.kumar

             Make sure that exact part number is selected in Device selector (Creator option) including Engineering Samples name in the part no.

               

             

               

            If you are facing issues with programming from Creator, try programming from PSoC Programmer. If you still face the issues, then take a screenshot of the PSoC Programmer settings and attach it here.

            • 3. Re: unable to acquire port
              james.litwiller

              Hello

                 

              I believe that I have damaged my CY8CKIT-001 by trying to get miniprog3 to acquire the port, using either PSoC3 or PSoC5 modules. should have come to forums sooner. Miniprog3 showed as unconfigured in win usb devices. Visual device id, (cycling LEDs) did perform ok. Error code dbg.M0039  - "There was an error running port acquire. There may be no devices attached or a device maybe in use by another application" occurred after left-clicking on Miniprog3 device, system very sluggish. I should have looked into unconfigured miniprog, (but it worked for PSoC1 module). Thanks if you can offer help.

                 

              JimL

              • 4. Re: unable to acquire port
                user_78878863

                On the -001, you also need to make sure the settings for the power source (Vbus vs. Vreg) matches with how you power the board (power supply vs. USB). And also check that you connect the MiniProg3 to the PROG header on the PSoC module, not to the TRACE header. (I did both things wrong last time :(