2 Replies Latest reply on Jul 16, 2013 1:00 PM by honey.gupta

    USBFS doesn't identify in Windows Device Manager Correctly

    jason.smith

       Hello -

         

      Using PSoC Creator 2.2; PSoC 5LP device (CY8C5868L), and I'm trying to get our USB information to display within Windows Device Manager.

         

      Within PSoC Creator; the USBFS -> USBUART component, I changed the Device Descriptor to our USB ID (0x2923) and changed the Product ID (0x501).

         

      In the String Descriptor tab; I changed the strings from Cypress information to our company / product descriptions, and saved / applied.

         

      When I rebuilt the project, and when the device first appeared under "Other" in the Device Manager, it showed as the product name I gave it.  However, when I point it to the driver, after it installs, it renames to "Cypress USB UART".

         

      I can't find where I'm supposed to change this (I manually changed the USBUART_1_cdc.inf file to include my company information, but that didn't change how Device Manager enumerated it).

         

      I tried uninstalling the driver, re-building the project, and then connecting again, and same result, it first identifies as I want it to, but after the driver installs, it re-names to Cypress USB USART.

         

      There must be a setting or step that I am missing, and appreciate any assistance in getting this resolved.

         

      Jason