4 Replies Latest reply on Jun 21, 2014 8:50 AM by grga

    File missing in WICED-SDK-2.4.1

    raghu1991

      Hi,

       

      I am using SN8200x Murata Wifi module and WICED-SDK-2.4.0.

       

      I tried to upgrade to WICED-SDK-2.4.1. But it seems the Wiced/Platform/common/drivers/spi_flash/SN8200x.c in WICED-SDK-2.4.0 is missing in SDK-2.4.1.

       

      Does WICED-SDK-2.4.1 support the SN8200x module ?

       

      Thanks in Advsnce

        • 1. Re: File missing in WICED-SDK-2.4.1
          grga

          Hello,

          You will need to get platform files from Murata.  Let me see best way to do this.

          kkoyama_1725561

          • 2. Re: File missing in WICED-SDK-2.4.1
            mifo

            If I'm not mistaken, Murata has their own document portal which contains software, patch files, along with some additional application notes that are not found on their public website.

            Portal access is for customers who purchased the SN8xxx EVK and within the EVK kit there are instructions to register along with a registration code.  Most EVK customers register for portal access early on, but many do not.

             

            They typically only grant access to EVK customers, although sometimes people start with the module first and I believe they may make exceptions on a case by case basis.

             

            prudhomme 


            • 3. Re: File missing in WICED-SDK-2.4.1
              raghu1991

              hi, Thanks for the reply.

               

              But WICED-SDK-2.4.0 by default has this file. I just need to add patches given by murata and compile.

              • 4. Re: File missing in WICED-SDK-2.4.1
                grga

                Given all the platforms we support and since it all has to be tested, It is too difficult to align the release of every SDK with the release of all module manufacture's platform files. We are planning to make these easier in the future, but right now you have to reach out to the module vendor and ask for the correct platform files depending on which SDK you use.