10 Replies Latest reply on Sep 14, 2013 6:35 AM by user_14586677

    PSOC 3, cannot acquire device (miniprog3/JTAG)

    user_190072030
              Hi, I am a hardware engineer, and I am pretty new to PSOC. I am unable to program my own board using the jtag interface on miniprog3. I have attached the PSOC portion of my schematic. I have successfully created a code project on the CY8CKIT-030 running an ADC, character display, and PWM module, but now I am working on a new PCB which uses a PSOC and another processor. That being said, I just want to show that while I am new, I am not completely clueless in all of this. I was intending to design this system so the PSOC was powered off of separate floating analog and digital supplies. I was trying to power quadrants VDDIO1 at 5V from the digital supply, VDDIO2 on the 3.3V from the digital supply, and quadrants VDDIO3 and VDDIO4 from the 5V on the analog supply. At this point, I am still uncertain if this is even possible. I have found no documentation or examples of anyone actually running 2 separate floating supplies. One mistake I made was pin 66 VSSD which was tied on the analog side VDDA, which was causing damage. After I damaged the first board in the run, I got another board from the run and cut and jumped so it was connected to digital ground. The processor did not overheat/fail like the first one. I have checked and double checked my JTAG connections. I believe they are all correct, but would be happy if someone could prove me otherwise . I have also tried connecting pin 10 of the JTAG connector to pin 25 nTRST (which is where I think it should be so I can debug) instead of pin 15 XRES. I have also soldered on pull-up resistors to TMS, TDI, TDO, and a pull down to TCK. I can see the programmer just fine. I have also tried connecting the grounds together of VSSA and VSSD, and that doesn’t help. I also have tried adding a 7.3 MHz crystal oscillator and 22pf caps to pins 42 and 43. Nothing seems to work. I cannot communicate or acquire the device in miniprogrammer or psoc creator. At this point I am suspicious this could be an oscillator issue, a power issue, or a JTAG connectivity issue, but I am out of ideas. I know some PSOCs can run off their own internal oscillator, but I am not sure if it has to be configured that way, or if it needs a crystal at least the first time it is programmed, or what.